Jump to content
HybridZ

Chandler347

Members
  • Content count

    6
  • Donations

    0.00 USD 
  • Joined

  • Last visited

  • Days Won

    1
  • Feedback

    0%

Everything posted by Chandler347

  1. Chandler347

    Solid 260z rolling shell, perfect v8 car

    Pm sent
  2. Chandler347

    Wanted: 240z, 260z, or early 280z

    Wanted: 240z, 260z, or early model 280z. I need one with all glass and a body with no major damage. Rolling body with a dashboard is a big plus. Im located near sumter sc, and can have family look at cars near louisville ky.my max price range is 8k.
  3. I have a 1987 ford v8 overboared and cammed in my 240z and the alternator is bad. I found out its a chevy alternator but is it okay to have that on there or should i get one to match the engine? The one on there i know will work and is already set up so i could just swap it out. Is there any down sides to doing this? Thank you!
  4. Chandler347

    Alternators on different engine

    Thank you for the help!
  5. Chandler347

    Rear window wanted for 1972 240z

    My rear window is broken and i need a replacement, i cant find any dealers that sell them. 1972 240z. Thank you!
  6. Chandler347

    Rear window wanted for 1972 240z

    The big hatch window
  7. Chandler347

    Power problem with turn signal lights

    Thank you everybody im going through everything and cleaning it and it's slowly getting more power to the light
  8. I have a 72 240z with a ford v8, the guy i got it from wired the brake lights to the turn signal and it works but the on/off of the signal is way too dim to notice is there a way to up the power or something? Im just looking for a quick fix so i can get it inspected then ill take it apart. Thank you!
  9. Chandler347

    Power problem with turn signal lights

    Ill check the TS switch tonight along with the grounds. I cleaned the socket and it has enough power to light up my power tester but not enough power for the bulb.
  10. Chandler347

    Power problem with turn signal lights

    I cleaned all the connections i could find and looked at some schematics but something is drawing too much power in the circuit to the actual rear turn signal light. It is working but only has a very very dim light coming from the bulb. I dont know if there is a connection somewhere that is likely bad since its original wiring.
×