Jump to content


Photo
- - - - -

ABS light and hum from rear of the car.

ABS z32 300zx brakes light warning noise hum pump

  • Please log in to reply
1 reply to this topic

#1 Pharaohabq

Pharaohabq

    Member

  • Members
  • PipPipPipPipPipPip
  • 1928 posts
  • LocationAlbuquerque, NM

Posted 25 September 2013 - 02:58 PM

So yesterday I was on my way home and my ABS light came on. This was disconcerting since it's NEVER come on before, not in the 17 years I've had the car.  So I was looking into the symptoms and aside from the light, there's a hum of a motor coming from the back right rear of the car. Shutting off the car clears the ABS light temporarily, but it comes back on after a few minutes even at idle. I checked the ABS fuse and it's good, I pulled the fuse and the hum continues.  I do still have brakes so that's good, but the motor noise continues even with the key off and out of the ignition.  I was worried I'd run the batter down so I got a wrench and disconnected the negative cable.  

 

Today I read around a bit and it seems this is a fairly common issue we'll see more of. The ABS relay apparently can get old and get stuck. Tonight I will open the panel and rap on the relay  then reconnect the power and see if the ABS pump still is humming. If so I'll pull the relay and it should from all accounts stop.  If that's the case I'll order the $50 relay and be done with it.  If a new relay doesn't fix the issue then it could be the wheel sensors or some other part.  I'll have to break out the FSM to see how it's tested.  Failing that it's a dealer diagnosis.  I'd much rather do it myself than pay someone to guess at the issue. There are some savvy Z32 mechanics around, but even at Nissan, the newer mechanics have barely touched these older Z cars.   I'll let you guys know what I find out and hopefully snap some pictures in the process.

 

Phar

 



#2 Pharaohabq

Pharaohabq

    Member

  • Members
  • PipPipPipPipPipPip
  • 1928 posts
  • LocationAlbuquerque, NM

Posted 05 November 2015 - 09:38 PM

just an FYI...   If you disconnect the battery, it'll turn this off and you'll be fine till it happens again..  2 times in 2 years isn't so bad, vs paying 50 bucks for a new relay.







Also tagged with one or more of these keywords: ABS, z32, 300zx, brakes, light, warning, noise, hum, pump

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users