Jump to content
HybridZ
Silver Mine Motors

240z LT1 T56 Comfortable Performance Build

Recommended Posts

Finally got the car back from the paint shop. It looks Looks beautiful! Been hard at work. Re-installing body parts, Changing bushings, sway bars and Installing the Lt1 engine and T56 trans. 

So far things are moving fast with minimal complications. Here's a few pictures

post-2140-0-10831200-1440384953_thumb.jpg

post-2140-0-05755000-1440384975_thumb.jpg

post-2140-0-65240000-1440385003_thumb.jpg

post-2140-0-15590500-1440385177_thumb.jpg

post-2140-0-85874000-1440385196_thumb.jpg

post-2140-0-74596100-1440385208_thumb.jpg

Share this post


Link to post
Share on other sites

Still working hard on the 240z. Been buying many parts and prepping the engine for the first start. Changed the clutch master cylinder with a Tilton unit. Running fuel lines and filters, changing oils, installing sensors and wiring. Deleted the A/C and powersteering pumps. Had a drive shaft made. Installed a WALBRO 255LPH fuel pump, and more. 

post-2140-0-84110500-1441474917_thumb.jpg

post-2140-0-69073300-1441474933_thumb.jpg

post-2140-0-38436000-1441474949_thumb.jpg

post-2140-0-55078300-1441474962_thumb.jpg

post-2140-0-10842300-1441474985_thumb.jpg

Share this post


Link to post
Share on other sites

Update: We installed the accessory and belt system. Aluminum radiator and Taurus fan with all hoses and water block off plugs. Sent PCM out to get flashed. Started building intake system. Currently working on all the wiring and sensors. We are getting very close to starting this beast. 

So excited to hear it run. I can't wait to start working on my favorite part; brakes and suspension. 

post-2140-0-55569500-1442455587_thumb.jpg

post-2140-0-35091400-1442455598_thumb.jpg

Share this post


Link to post
Share on other sites
Been working 240z. Installed front and rear wilwood brake upgrades. Installation was easy.
Also installed new Tie rods, Ball joints, Rack Boots, Lowering Springs and Tokico Shocks.
Finished most of the engine just waiting for parts. Also need to change the fuel hard line since it's leaking.
I made these how to install videos for the brakes:

 

post-2140-0-36310400-1447523678_thumb.jpg

post-2140-0-57959200-1447523728_thumb.jpg

post-2140-0-35441600-1447523742_thumb.jpg

post-2140-0-40166700-1447523771_thumb.jpg

post-2140-0-14932100-1447523802_thumb.jpg

post-2140-0-33415800-1447523823_thumb.jpg

post-2140-0-41260900-1447523852_thumb.jpg

Edited by Silver Mine Motors

Share this post


Link to post
Share on other sites

The 240z model was a very loud and uncomfortable car. I'v herd it compared to a coke can on wheels, and I kinda agree.

 

That's why we installed rubberized Sound deadening on our interior. I'm hoping to reduce the road noise significantly.

 

Also installed rear 7/8 sway bar.

 

Realized our gas tank was full of rust so it is being chemically cleaned now. Check out the picture of the inside of the gas tank before treating. pretty rusty! Can't wait to see how it looks when it's back from treating.

 

Started installing some exterior lights and emblems which were all restored.

 

New Complete carpet kit being installed next. 

post-2140-0-13035800-1448514369_thumb.jpg

post-2140-0-84559600-1448514390_thumb.jpg

post-2140-0-06802600-1448514408_thumb.jpg

post-2140-0-87564900-1448514420_thumb.jpg

post-2140-0-29250600-1448514453_thumb.jpg

post-2140-0-14533000-1448514467_thumb.jpg

post-2140-0-30855700-1448514482_thumb.jpg

post-2140-0-94662800-1448514522_thumb.jpg

post-2140-0-61187000-1448514546_thumb.jpg

Share this post


Link to post
Share on other sites

Finally got the car back from the paint shop. It looks Looks beautiful! Been hard at work. Re-installing body parts, Changing bushings, sway bars and Installing the Lt1 engine and T56 trans. 

So far things are moving fast with minimal complications. Here's a few pictures

What mounts are you using for engine and transmission?

Share this post


Link to post
Share on other sites

Been working on the car some more. Got a new used gas tank and welded an external sump on it. Then had it professorially cleaned and re sealed.  Installed AN fittings to a Huge fuel filter with cleanable  filter screen.  installed a WALBRO 255LPH fuel pump. Re installed the door panels and seats and many other interior parts. 

 

Car would not start for months while We tried everything. In the end it was the third opti spark unit that works. We also converted the LT1 ignition system to use 8 x LS1 coils, using Bob Bailey LTCC kit. Now the car runs great! Fast and even a little scary. 

 

Sorry for the late reply, I bought the roll cage as a general kit. It had to be re bent and modified to fit, plus I added a few extra parts. 

 

20180717_183015.thumb.jpg.1c8c591f41e1128843fce25a60e9d9c9.jpg20180717_183034.thumb.jpg.6dd1a3e34d6f9e542bf31fc02df4193e.jpg

20180717_183009.jpg

20180717_183107.jpg

20180717_183122.jpg

20180717_183134.jpg

20180717_183202.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Installed new weather stripping on the doors and rear hatch. Car is more quiet and it smells less. 

Also installed LED headlights. These lights are really bright! This 240z did not come with relays for the headlights. This caused my headlight switch to smoke and melt so I installed a relay system. 

Also my rear brakes were to strong and locked up before the fronts. I installed a adjustable Wilwood prop valve on the rear hardline coming out the master cylinder and turned down pressure on the rear brakes. Now the bias is perfect!

 

20180718_133522.jpg

20180718_133440.jpg

20180718_133431.jpg

20180727_124117.jpg

20180727_124135.jpg

20180723_110435.jpg

20180723_110508.jpg

Edited by Silver Mine Motors

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×