Jump to content
HybridZ
mrk3cobra

JDM tail lights not connecting to US 240Z

Recommended Posts

mrk3cobra    0

I just purchased a set of new JDM tail lights from Futofab, the harness connector is different from the OEM harness on my 1971 240Z. Does anyone know which is the correct harness connector, Futofab says is should plug in the OEM harness. You can see from the picture the connecters are totally different. Has anyone had this problem. Is there an adapter to go from the JDM style to the 240Z style connector? Is my car different from all the other 240Z's.

 

The picture on the right is the JDM connector.

 

Pete

post-54185-0-25484000-1503596748_thumb.jpg

post-54185-0-06968900-1503596776_thumb.jpg

Share this post


Link to post
Share on other sites
JSM    15

Should be able to reuse your old harness as the sockets should be the same.  There is a wiring fix you need to do at the light switch to separate the blinker function from the tail lights so the tail lights work correctly (No brake light via the Amber lens.)

 

http://www.classiczcars.com/topic/32228-modify-us-240z-rear-turn-signal-wiring-jdm-style/

 

This is one but there are others I've seen too.

Share this post


Link to post
Share on other sites
mrk3cobra    0

Yes I sent  pictures to Futofab they said they do not know why my car is different (they work with there 1971 240Z). I guess I will order new connectors that match and re- wire. My old harness is rusted I do not want to re-use it. I was just wondering if I really have different connectors than other 1971 240Z's.

 

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×