Jump to content
HybridZ
Sign in to follow this  
JLuff240

First Project post - BadDog Missing?

Recommended Posts

First HybridZ post here. Loving my new project car...

 

But, I ordered Bad Dog frame rails for my new to me 240z last monday. I got a notification that payment had been received by John through paypal. I sent an e-mail last friday asking for an update. But, have yet to hear any response. Does anyone know if they are in fact still making parts, or anything? Should i cancel my order and just use the rails that are going to come with my floor pan kit? Long term i plan to make 300+HP at the wheels. A friend of mine told me that if i plan on that much power i should go with that BadDog rails for increased rigidity in the frame.

 

I've uploaded a couple of photos from before loading it on the trailer and getting it home for a quick cleaning.

IMG_2920.JPG

IMG_2937.JPG

Share this post


Link to post
Share on other sites
16 hours ago, Ryanotown22 said:

Yeah it seems like it.  Mine showed up perfectly packaged no issues at all.  I got an email when he took them to fedex with tracking number.  It was a little over a week I believe after paying 

 

Thanks, i'll be patient and on the lookout. 

Share this post


Link to post
Share on other sites

Well, i feel dumb... I got an e-mail that looked like and automatic response from paypal and wrote it off as nothing. Turns out it was actually a message from John, w/tracking information. He shipped the rails last Wednesday... two days after i placed the order and they should be here today. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×