Jump to content
HybridZ
5thgenluder

1971 240z rb25det build thread

Recommended Posts

I just got done binge reading the whole thread.. just wanted to say thank you!! for taking the time to explain, taking and posting pics, answering questions and posting links.. I know all of this is time consuming,but you still took the time..

I purchased a 72 240z with a blown head gasket a couple of years back (man..time flies) didn't even give it a second thought.. I knew I wanted an rb engine in it. after sourcing one about a month later, an aggressive tear down began, within a couple of weekends engine, tranny, fuel tank and even the rear end was out of the car..and then.. yep you guess it ..NOTHING!! ... anyways enough of my winning..

Thanks again for your thread.. it's been?? In a word reEnergizing!!

post-46089-0-03508400-1484410278_thumb.jpg

Share this post


Link to post
Share on other sites

I just bought my first car. It's a '72 240z. The previous owner said that the engine had some minor problems but after further investigation its too far gone to restore. I guess I'm in the same spot you were some 7 years ago. I'll be using this thread as a bible. Great job on the build, i can only hope mine will turn out as good as yours.^_^

-Johnny

Share this post


Link to post
Share on other sites

4.6 that is one of my all time favorite dash boards. I have drooled over the idea for a while. Unfortunately it is out of my current budget. I have been working on the car getting it ready. I have been tinkering with the wiring trying to get it all working. Im gonna need to update my wiring guide. I was having issues with the front parking lights coming on when I hit the brakes. I got the remainder of the original sound deadening off the floor pans. I wire wheeled them clean, rust encapsulated them, then put some dynamat down. I also used some fiberbondo to smooth the dash and then some resin as to smooth it even further. Im gonna post some pics of some of teh progress.

attachicon.gifsteering column wiring.jpg

attachicon.gifdynamat 1.jpg

attachicon.gifdynamat 2.jpg

attachicon.gifDash top.jpg

attachicon.gifdash front.jpg

Hey mate, I know this is a very old post but I am doing the exact same thing in my z with the EZ 21 relay. I'm mounting mine in the exact spot as yours I've found, and I'm curious how exactly you did it? It seems the easiest way is to get two long sheet metal screws and just drill em in, is that what you did? if you have any pictures that would also be helpful! Let me know pretty please with sugar on top haha. Regardless, rad build!

Edited by Jboogsthethug

Share this post


Link to post
Share on other sites

Whats up guys! 

 

First off, awesome build man! Great job! 

 

I also have an rb25 73 Z . 

 

I have an issue. If I am at a quarter tank the car suddenly dies. I filled her up the other day and she is not idling correctly. When parked, i rev it and it seems to want to turn off. I do not have a surge tank, or any filters. Could this be my issue? I just got the car running and doing work on it as i go. Also cleaned out the AFM and made sure i had no vacuum leaks. I had to change out my turbo because my last one the compressor wheel blew up lol. I got an s1 turbo with steel wheel. She pulls hard but i am not sure if wastegate is opening. I have no boost solenoid. Any ideas guys? 

Share this post


Link to post
Share on other sites
On ‎1‎/‎12‎/‎2018 at 4:47 AM, Agarc315 said:

Whats up guys! 

 

First off, awesome build man! Great job! 

 

I also have an rb25 73 Z . 

 

I have an issue. If I am at a quarter tank the car suddenly dies. I filled her up the other day and she is not idling correctly. When parked, i rev it and it seems to want to turn off. I do not have a surge tank, or any filters. Could this be my issue? I just got the car running and doing work on it as i go. Also cleaned out the AFM and made sure i had no vacuum leaks. I had to change out my turbo because my last one the compressor wheel blew up lol. I got an s1 turbo with steel wheel. She pulls hard but i am not sure if wastegate is opening. I have no boost solenoid. Any ideas guys? 

Best to start a new thread for this as not to clutter up his build thread

  • Like 1

Share this post


Link to post
Share on other sites

It’s been a long time since I updated this thread.  You all deserve better.    I didn’t get much done on it last year.   I purchased a house and have been remodeling that for the last 2 years. So unfortunately the z went on the back burner.    Here’s what went wrong.   

 

The headlights stopped working.  Turns out that the high beam lever on the stalk broke apart on the inside. It looks like it had a spring in it that moved a contact point.   Have yet to find a replacement.   Wired it out for now and put my high beams on a switch.   

 

Radiator leaked.   I need to find some better fitting radiator hoses.  I found what I could at autozone when I did the engine swap but they aren’t perfect.   

 

I spent a good good couple days rewiring my dash.   It was a rats nest and was completely unserviceable.  Added some molex plugs so that thing like gauges and the dash itself can be removed.   

 

This spring I plan to make it more of a priority and get some more done on it.   

 

Funny story.   I really thought I had a rare car until I show up at a small car meet 20 miles from my car and another rb z pulls up and parks next to me.  74DBD849-63B8-426B-BA11-CAC73C6323B1.jpeg.0e0c614698734baa73053b908daf2e04.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×