Jump to content
HybridZ

grenadesandham

Members
  • Content Count

    2
  • Joined

  • Last visited

  • Feedback

    0%

Posts posted by grenadesandham

  1. Hi guys, first time posting here, working on my first RB and I need a little help!

    I'm having a weird problem with the RB25 I built for my 280z. I just recently put in the motor and haven't gotten it to start yet. I am using a Haltech pro plug-in ECU so that is helping immensely with diagnostics but might be part of the problem lol. So basically I have been able to crank over the engine but I am not getting any signal from the crank angle sensor, which in turn (correct me if im wrong here) is giving me no RPM signal, and not allowing the injectors or spark to fire. Essentially the ECU is unaware the engine is turning. I checked the power and earth of the connector, and also checked continuity from the ECU plug to the CAS, and made sure it was the correct pins for the ECU. Its a brand new wiring specialties harness. On the Haltech I made sure the trigger type was set to the correct one and opened a trigger counter channel so I could see if the ECU was getting any pings from the sensor (nothing). Every time I plug in the CAS with power to the ECU I do get a ping so im thinking the ECU should be okay? So, I got a new (used but in beautiful condition from japan) CAS and hooked it up, thinking that would solve the problem but it persisted. 

     

    I found it unlikely that I would get 2 bad CASs in a row so I tried to bench test my new one. I gave it constant 12v to the power pin and strangely got 12v out of both data pins no matter what position the shaft was in (this might be just how it is but I would think you would only get voltage at the 1 & 120 degree positions?) I am just using a multimeter though so without am oscilloscope its hard to tell what is going on. Not sure what I should be seeing or if I would even be able to see anything at all.

    I have a series 2 with the black plastic CAS

     

    TL;DR

    Are these CAS sensors known to go out or am I doing something wrong? They are expensive but my next step is to get a brand new one from Raw Brokerage when they get them back in stock because I can't think of anything else that could be going wrong.

    Thanks in advance

×
×
  • Create New...