Jump to content
HybridZ

What did you do to your Z today?


Recommended Posts

  • Replies 516
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Took a picture of the 280zx sitting outside after the storm.         It was a busy day

Dynoed it.   http://www.youtube.com/watch?v=1bBWuzgUgIA

Opened the boxes containing my new AZC big brake kit and immediately got a boner.

Posted Images

Found out my right front Tokico blue strut is blown... I then proceeded to contact the place I bought the spring/strut combo from to try and get the warranty.

Turns out Tokicos US distributor has gone bankrupt...
No new stock until at least the end of the year as they are trying to sign a new deal with a new distributor...
I guess I might have to bite the bullet and just buy a new front set of struts myself or try to find somewhere that has some Tokico blues in stock (which nowhere does...)

Any ideas?

Link to post
Share on other sites

Found out my right front Tokico blue strut is blown... I then proceeded to contact the place I bought the spring/strut combo from to try and get the warranty.

Turns out Tokicos US distributor has gone bankrupt...

No new stock until at least the end of the year as they are trying to sign a new deal with a new distributor...

I guess I might have to bite the bullet and just buy a new front set of struts myself or try to find somewhere that has some Tokico blues in stock (which nowhere does...)

Any ideas?

 

Sounds like the perfect time for coils!

Link to post
Share on other sites

Today was one of those less than pleasant days.  2 Weeks ago I had achieved all of my goals for work to be done to the 240Z this summer, hah!  No smooth sailing for me.  My battery died today and the car wouldn't start.  Had the battery tested, and it showed as bad.  Of course the PO I bought the car from had one of those Optima gel cell batteries in the car, so I bit the bullet, avoided the downgrade in part, and bought another.  All good, new battery, the car is running, and now I have a battery warranty, so all isn't so bad!  

2 hours later, the new battery is dead... Guess it might have been the alternator, and rather than being lazy I should have pulled it for testing also?  Bah!  It was 9pm and I was 40 km from home, the tow of shame for me....  

Will have to pull and test the alternator tomorrow.  All of the wires and grounds look good, so that's what it should likely be.  The real fun will be in finding a replacement for it, as it's an Accel "Racing Alternator" #8080, whatever that is.  Looks to be a Delco bodied 3 wire GM alternator, we'll see though.  The PO had a bit of the mad scientist in him, and I kind of wish he kept more documentation with the car...

Link to post
Share on other sites

Got the turn signals to work (don't work if unplugged), Got the numbers to light up on the tach, only had the needle lit firsttime. 

 

Buffed the hood, roof and rear decklid. Tried to get the water spots out. About 95% of them. Used my dads variable speed buffer with some meguiars ultra cut 105 and ultra finish 205.

 

20130815_205319_zps6a099059.jpg

 

Tried some rubbing compound on the front wheel, then polished it. Got about 90% of the brake dust burned into the wheel off. Looks better. Just need to do the other 3

Edited by tooquick260
Link to post
Share on other sites

Finished 3 months of fabrication work turning the Z into a dedicated NASA "Race Group" legal track car.

Today, the painter comes to start 2 weeks of paint work and I cannot be happy enough ... 

 

Many thanks to my flock of helpers for putting in so much time to get all the work done.

 

Looking forward to seeing a video of the new-and-improved Z in action!

Link to post
Share on other sites

75 parts z heads to the scrap yard today!  Friend calls this week and offers me his 77 280 [a new donor/parts car] after a friend he sold it to realized it was too rusty

.  Will go look at it next week!  Has the title, keys and all the parts including a spare dash [not sure of condition], used header and factory 5 speed-i'm excited for another project.

 

Haven't touched my 73 since returning from ZCON in New Hampshire...

post-176-0-29421600-1377355055_thumb.jpg

post-176-0-62147900-1377355068_thumb.jpg

Edited by 1 tuff z
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...