Jump to content

Trouble shooting Z31 ecu install

Recommended Posts

I have an 88 turbo ecu that has been tuned by. Set up for 500cc injectors and to run a z32 maf. 


Installing on a L26 motor that has P90 head, shneider reground cam. Car has 8.5 to 1 compression. Drove the car for the last 5 months on stock 83 ecu, stock injectors. Ran ok would not run on over 6 lbs boost above 4000 rpm.


With the new injectors I soldered in new wire connectors. I installed the chopper wheel from a 300zx turbo distributor and installed it the same way it came out, unless the prior owner had it out and was in upside down to start with. I installed the z32 maf wired the same way that a cobra maf would. Victor said he took care of the resistors at the plug in side to take care of the difference in volts 2-7 compared to 0-5.


I plugged the computer in , attempted to start and it did not start. Checked for fuel and have pressure on the fuel rail. Pulled a plug to see if gas was present after attempting to start and it smells like gas with some wetness to the plug. I here clicking coming from the injector solenoids.


I then check for spark at the plug. I DO NOT HAVE SPARK. I pulled the coil wire off the distributor and no fire there either. Now I drove this car last Saturday and started this install that afternoon. Nothing has changed.


I checked the computer and I have power at the pin 35, 27 when ignition is on. 35 is suppose to be the C.A.S. and 27 is for afm. Now, Pins 8 and 17 are also for the C.A.S. but do not have power when the ignition is on. 


Why do I not have spark from the coil? 

Edited by tooquick260
Link to post
Share on other sites

Ok,, since i have only had conversations with 2 people about this issue,,,,, Thank you CGSheen and Bernard,,,,,,, I have taken more time to look into this swap that I am trying.


Per the following 2 diagrams that are electrical for 280zxt and pin out designation and per 300zx eccs there are more than just the infamous fuel pressure relay (FPR, pin 108 and 16) and the coil wires +/- to 34 and 3 and afm/maf differences.


Pin 6 on the z31 eccs says it is for efi main relay. s130 is blank. 

Pin 5 on the z31 eccs says it is for ign on, s130 is to fuel pump relay/fuel pump

Pin 20 on the z31 eccs says it is for fuel pump relay, s130 is to eccs analyzer

Pin 27 on the z31 eccs says it is for AFM, s130 is to ISC, EGR, EFI relay.

Pin 24 on the z31 eccs says O2 sensor for N/A, s130 is to the same but(this is not n/a) Should be pin 110 for turbo titania

Pin 22 on the z31 eccs says FICD , s130 is for a/c switch

Pin 35 on the z31 eccs says CAS, s130 EFI relay switch

Pin 34 on the z31 eccs says ign switch, s130 is blank

Pin 108 on the z31 eccs says fuel pump relay, s130 air regulator


So, am I reading this wrong? Looks like you need to.....


pin 6 put in the 280zxt harness and run to the efi.

Pin 5 needs to be to ign on.

Pin 20 i can skip if I am going to run fuel pump with ignition on no relay.

Pin 27 spliced into the maf/afm.

Pin 24 wire needs to be moved to pin 110.
Pin 22 skip cause not using that.

Pin 35 i don't know?

Pin 34 install connector run to ign on.

Pin 108 ignore because not using relay same as 20


Above is wrong see link to fsm diagram below for comparison




Edited by tooquick260
Link to post
Share on other sites

Stop!  If you haven't already, get the '88 FSM EFEC Section from nicoclub.com/fsm

EF&EC-11 shows the circuit diagram for the Z31 ECCS.  Pin 5 is NOT IGN ON.  Pin 5 is output to the Ignitor (Power Transistor) - same as on the L28ET ECCS so leave it alone!


You need a better drawing or comparison chart for the pinout differences in the 2 ECUs...  What have you re-wired already?

Edited by cgsheen
Link to post
Share on other sites

I have only tried plugging in as is. Per the tuner that is not helping me now. Said the ones he has done all he did. Supposedly per the jimwolf page.


When that did not work, I tried the 34 pin wired to the positive side coil and 3 pin to negative side of the coil. That is all I have tried.

Link to post
Share on other sites

Ok so runs. I had the wire from the ignitor to the ecu pin 5 pinched under the coil bracket. Stupid me was cleaning up some wiring and had the coil bracket off. Stupid I know.


Car will idle but goes into a limp type mode if you try to rev the motor. Real rich on idle and goes rich/lean trying to rev the motor. Don't think the MAF is reading correctly.

Link to post
Share on other sites

88 doesn't have a limp mode.  If you can't take the time to read the whole thing at least read pages EFEC-20 to EFEC-23.  You'll be miles ahead of where you're at now.  You can't guess your way to success without understanding at least the most basic elements of the engine's control system.  The computers used are primitive.  Guessing at limp mode is one example of how you can get side-tracked.

Link to post
Share on other sites
Fuel Injection Control System

Fuel is shut off above 

2.000 rpm. 

(Engine speed does not 

exceed 2.000 rpm.)


That is from the 88 FSM. EF & EC-29 Fail safe system. Air Flow Meter.


So not a limp mode but a fail safe mode. Concurs my finding of the car running the same with maf plugged in or not. And the values reading of 1.2 volt reading at the signal wire while idling and not much change when reving.
Link to post
Share on other sites

Ok did that and is flashing 1 red 2 green. Went to EFEC-86 and says that the volt reading at idle should be between 2-3v, 2-4v under rev. I was only getting 1.2 on idle and would not go over 2v revving. 


Which this z31 ecu works on 2-7v and the z32 maf operates on 0-5 volts. Makes me think the maf is working but the computer is not reading what it thinks it should be and cutting fuel off.


Per EF&EC 174 in the 1993 300zx FSM the maf should read .8 to 1.2 on idle and .8 with ignition off which is what I get testing the MAF.

Link to post
Share on other sites

I followed Bernard advice to look at the Nistune page for rom installation. It has section nine about installing later model lower voltage MAFs on the Z31 ecu. It says to remove 2 long transistors and one small transistor. Here is the link, page 29.





So I did this and the car started and idled smoothly. I only had the MAF wires twisted together. It revved up and sounded great, then went totally lean. Since idled and ran well for a short period I attached connectors and re-plugged in. Car started up and revved up. Straightened up everything went for a drive, first down the street. Ran great. Then around the block even better. Went back to the house and picked dad up for a quick ride. Went to the end of our dead end back and pulled better than it ever has. Decided to take for longer trip with dad and made it about a mile away and the car died. Starts but is not firing on all cylinders. Had to call mom to tow home. 


My dad said that I need to put the air cleaner on when driving it because of the air flow and the dual electric fans will affect the reading on the MAF. Still does not answer the issue of just dying and not starting running on all cylinders. 


Will follow up with results. stopping to enjoy the holiday burgers on the grill.

Link to post
Share on other sites

Ok this morning before going to work did some more investigating.


Per bernards instructions and reading the FSM further I started car and pulled injectors one at a time. Had 3 make no difference in the way it idles and 3 would almost make car stall. Didn;t know it would run on 2 cylinders. Doesnt run long on 3 for that matter.


So pulled plugs to confirm, 1,2,3 pulgs are clean just like i put them in and have no fuel smell. 4,5,6 are sooted and smell of fuel. 


Now onto why they don't. I will try tonight when I get home to see. Ground wire maybe?

Link to post
Share on other sites

Well stupidity prevails......



Found a ground wire that was not attached. Can you say duh. This was a wire that I moved during the new ecu install.  It was one of the 2 fatter grounds from the harness in the engine compartment. I reattached and it did not help. 


I did an ohm test on the 6 injector connectors and the 3 that are not working have 001 and the 3 that work are reading 008. This could have burned out the injector driver in the ecu. 


The tuner is going to send me another ecu with the socket plug installed, I will switch in the rom chip and hopefully be ready to go. 

Link to post
Share on other sites

Still waiting on the ecu from the tuner..... From talking to more people about the ground wire issue, was told that there has to be something else. So a friend of my dads came over and looked at what we have. He narrowed it down from the 3 injectors not working to 1 injector with a problem. This connector had power to both sides, Where the other 5 only had power 2 one wire. Cut the heat shrink open and...................


When my dad soldered the new injector connectors onto the old harness he left a very sharp point on the soldered wires. He heat shrinked one of the 2 wires but did not heat shrink other, then heat shrinked the 2 wires together from harness to the injector. The sharp point punctured through and contacted the other wire. This is what damaged ecu driver from the high voltage of 2 wires contacting them selves. 


In process of cutting all the heat shrink off the newly connected wires to make sure it does not happen again. We did plug the stock 86 ecu in and started up on all 6 cylinders. Ran rich (500cc injectors) and did not work well with the Z32 maf....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...