Jump to content
HybridZ
Sign in to follow this  
TakemuraShuu

1978 s30 Tach wiring help

Recommended Posts

Hi everyone, I have a 1978 280z that I've been working on for over a year now. In this time, I've got everything working from the drivetrain to the gauges (all except the tachometer), I usually drive it everyday. The tachometer is the only thing that doesn't work, and hasn't ever since I've had the car.
 
I removed the tachometer from the dash and tested voltage, it is a 3 wire tach. With key in ON position, Red/black wire going to peg has 10.95v, green has 10.96v, and the black is a GROUND I'm assuming.
 
I bought an aftermarket unit assuming the tachometer itself was bad. Installed it according to the wiring diagram. When I turn key to ON position nothing happens, when I start the car the aftermarket tach flashes once for a split second, but doesn't come on, the needle does not move either.
 
Is there an in-depth diagram on the wiring of a 78 z, I'm mostly finding write ups on 240z's. Any help would be greatly appreciated, thank you so much.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...