Jump to content
HybridZ
Sign in to follow this  
Boss Loaf

Trouble Wiring MSD Tach Adapter in 1978 280z

Recommended Posts

Alrighty, Ive got a stock 1978 280z and I'm currently installing an MSD 6A and Blaster 2 coil into the car. After reading any and all forum posts on the topic I came to the conclusion that I would need an MSD Tach Adapter 8920 in order for the MSD box to Communicate to the EFI by upping it to 12v. All my wires are in place and I'm getting a good strong spark. I put a voltmeter on the purple wire coming out of the MSD tach adapter and I'm getting 12v. Only problem is that I'm getting no fuel. It must not be communicating with the EFI somehow.

Here's my Setup.

MSD 6A:
Heavy Red goes to battery +
Heavy Black is going to battery -
Red is going to Black wire with white strip (Ignition Key Wire)
Orange is connected to blaster 2 coil +
Black is connected to blaster 2 coil -
White is not being used, I do not have a points system
Violet and Green are connected to the Magnetic Pickups (I was told it didn't matter which way, I put green to green and violet to red)

MSD Tach Adapter 8920:
White goes to Tach Output on MSD 6a box
Black is ground wire
Red is connected to Black wire with white stripe (so two reds and black with white stripe all connected)
Violet is connected to the blueish green wire that was connected to the coil negative terminal.


Summary:
I don't know what the **** I did wrong. Someone please tell me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...