Jump to content
HybridZ

Recommended Posts

I have a friend that just wrecked his Viper and asked me if I was still interested in a t56.  I can get it at a good price but wondering what it will take to get it to work in my 73 240z with a 5.3 LS motor. Right now it's an automatic transmission.  I was hoping one of you guys had some experience you can share.

 

Thanks on advance,

Share this post


Link to post
Share on other sites

Check if Viper motor fits in S30.  If it does get the motor too!  Mating the Viper trans to an LS block means different bellhousing and input shaft I believe, a major hassle.  Google Viper and Chevy T-56 differences to confirm

Share this post


Link to post
Share on other sites

I used a viper t56 in my datsun. I’m not sure about differences in year (my t56 was out of a 98 viper) but I had to get an ls input shaft and bellhousing. The throw out bearing retainer has the 2 holes clocked differently too, but I think I just reused a viper one because I don’t remember drilling any holes in mine. I used an ls7 clutch kit.

Share this post


Link to post
Share on other sites

The three slave cylinders pictured Left to right are ls1, ls7, and viper. I just reused the viper one because the bolts lined up with the viper t56 faceplate and it was the same measurements compressed and extended as the ls7 slave cylinder. The hardest part is getting the input shaft in. I paid bob hanlon motorsports to do it.  You also need a shifter, I believe the viper one is offset left and forward. I used an mgw shifter for the adjustability and had to cut a new hole in my trans tunnel.

C0413882-861F-4CA0-8C73-273B4896B408.jpeg

Share this post


Link to post
Share on other sites

I am using a Viper T56 also. I swapped the bellhousing and Input shaft to LS1 and the too. It's been a while since I did it but I pulled the front plate off and the input shaft is sitting right there and that's all I had to mess with. I believe I just pulled it off(front plate) and swapped the LS1 shaft on because its shimmed and held in place by the front plate.

Share this post


Link to post
Share on other sites
On 7/15/2020 at 11:40 AM, JQADDINGMACHINE said:

I used a viper t56 in my datsun. I’m not sure about differences in year (my t56 was out of a 98 viper) but I had to get an ls input shaft and bellhousing. The throw out bearing retainer has the 2 holes clocked differently too, but I think I just reused a viper one because I don’t remember drilling any holes in mine. I used an ls7 clutch kit.

What year bellhousing and input shaft?  Did you use corvet or camaro input shaft and bellhousing?

Share this post


Link to post
Share on other sites

It should be safe to use 1999-2002 Camaro or Trans Am bellhousing and input shaft. I'm not sure about the corvette bellhousing but you can;t go wrong with the 99-01 Camaro/Trans Am. You can google LS t56 Input Shaft and find various prices on them. 

Share this post


Link to post
Share on other sites
10 hours ago, Daz said:

It should be safe to use 1999-2002 Camaro or Trans Am bellhousing and input shaft. I'm not sure about the corvette bellhousing but you can;t go wrong with the 99-01 Camaro/Trans Am. You can google LS t56 Input Shaft and find various prices on them. 

Thanks, that's great information.

Share this post


Link to post
Share on other sites
1 hour ago, milesz said:

Thanks, that's great information.

One more question, if I stay with the Viper mid-plate, what slave cylinder do I need to get?  Can I used any Dodge slave cylinder is only from a Viper? 

Share this post


Link to post
Share on other sites

I stayed with the Viper mid-plate and hydraulic TOB. I went with a Tilton 75-Series MC(p/n#75-280, 7/8 bore). It fits perfectly in the stock location. 

 

NOTE: I haven't actually tested this setup out. I had my car running at one point last year but I don't have a driveshaft yet(I would like to hear your input on that. I have a s13 rear subframe with a q45 diff)and decided to switch from turbo to LSA S/C. 

Share this post


Link to post
Share on other sites
9 hours ago, Daz said:

I stayed with the Viper mid-plate and hydraulic TOB. I went with a Tilton 75-Series MC(p/n#75-280, 7/8 bore). It fits perfectly in the stock location. 

 

NOTE: I haven't actually tested this setup out. I had my car running at one point last year but I don't have a driveshaft yet(I would like to hear your input on that. I have a s13 rear subframe with a q45 diff)and decided to switch from turbo to LSA S/C. 

Do you have any pictures you can share?  What clutch set up did you use? Thanks for the information.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...