Jump to content
HybridZ

Recommended Posts

19 hours ago, montyz81 said:

All, 

I am installing a megasquirt system in my 81 turbo (has an 82 engine in it). When I hook up the ignition coil, do I keep the factory wires hooked up along with the the new MS wiring?  I’m assuming I need to in order to keep the tachometer working.

thank you for your help. 

Anybody? I want to make sure I don’t fry anything attached to the original wiring Loom or the new Megasquirt system.

Link to post
Share on other sites

So. I got the car running, but the tach doesn’t work When I hook up the ignition coil, what do I do to keep the tachometer working?  Connecting the factory wiring along with the megasquirt coil wires causes problems. The spark plugs seem to fire at the wrong time. Without the factory wiring hooked up, the engine seems to run smooth. What do I need to do to get the tach working again.

Thank you for any advise you can give me.

Link to post
Share on other sites

what manual or instruction set did you use to hook everything up?  was there any mention of that problem?

 

I seem to recall some forum or another talking about this type of issue, but that was a few years ago;  I don't remember where... or how much details there was..

 

and when you mention the factory wiring, I imagine you mean all those wires that are connected to the cold that lead back to the tach (I think that's how it's set up, I didn't do the MS installation on my car so I'm not sure how it works). I know my car still has some of the old wiring attached to some of the posts on the coil.. probably exactly for that...  

 

 

Link to post
Share on other sites
  • 2 weeks later...

There's some diagrams out there that show how you can make your own circuit using a diode and a automotive relay and it works for s130's.  I drove my stock tach that way for the past 7 years.  It recently quit and I decided instead of troubleshooting the circuit (which was a bit redneck the way I installed it initially) I would just get one of the diyautotune tach adapters.

Link to post
Share on other sites

Its been awhile since I have looked at the Megaquirt systems, there a a few different ones now-a-days. On some of the models the tach gauge signal wire is re-routed to the MS box. Or you should be able to splice in the ignition signal before it gets to the MS box. Either way its not so plug and play.

 

How are you liking the MS, smoother running, easier DIY tuning?  I have been wanting to do it to my mustang project.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...