Jump to content
HybridZ

JCI 4l60e driveshaft fitment question


Recommended Posts

bummer was really hoping for a yes that is normal answer! 
 

Here are some more measurements.  The transmission shaft sticks out about a 1/4 to 1/2”. The yoke is about 3 3/4” and the splines go all the way to the edge  


I can’t math real gud but that leaves about 2 1/2” of spline contact. 
 

My gap is 1 1/2” If the normal gap is 3/4” would it be worth redoing the shaft to add 3/4” more contact? 

 

5A8DFBD3-515C-44DD-A850-B6F918E5607D.jpeg.ae18cf0a8e34cd951bb59bdb52ba9ca7.jpeg

1E34A057-CF1A-4201-9FCE-F8E3F624842E.jpeg.ba850ebc5dd109d31bd4a0f0bee36526.jpeg189A2471-E480-4410-BF95-CA2BF437189A.jpeg.66c763424afd933c0f8e33a8fc9fd2c2.jpeg

Link to post
Share on other sites

I hear you, in my case I had no choice. Mine was leaking from the rear seal. I replaced the seal twice and still leaked. I was also told that not having proper engagement could damage the transmission bearings in time. You can always try it like I did, if you have no leaks or vibrations you may be ok. 

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...