Jump to content
HybridZ
rookie z

clicking noise when backing up

Recommended Posts

Might want to check your Ebrake cable, mine fell loose and rubbed against the drive shaft, not good. How is the condition of the rearend? oh, and check that nut that holds it down, there is only one right under it but if its loose your rearend will clunk. maybe ask a friend to slowly back it up while your checking things out to get a better idea.

Share this post


Link to post
Share on other sites

I was shocked and relieved when I found it. I was sure it was something expensive, like the diff or axels. Apparently the diff pivoted down enough to allow the flange to hit the sway bar when I backed up.

 

thanks , i will check that .never thought about that but i will let you know.

Share this post


Link to post
Share on other sites

So it it sounds/feels fine driving forward, no clunks, clicks, etc. But in reverse only, it clicks.

 

Is the clicking dependent on amount of load being put it the drive-train while backing up, or all the time as the car is rolling, such as coasting in reverse?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...