Jump to content
HybridZ

Recommended Posts

Got the cars off the  boat, other than being filthy, they're both in good shape, no damage, fired right up etc.  

 

Just a few quick  shots of the intake configuration.  I finished this literally the night before we drove the cars down to the port.  Kinda wonky swinging around to the other side, but there's no room for the air filter in front of the radiator, and no room on the driver's side, so it works over there.  I like the idea of it pulling from a 'cold air' intake, but for now the hood vent above it will have to do. The blue elbow coming off the throttle body was kind of a pain to fab up; in the end it came out pretty well, for what it is.  Took it out the other day, and while there's still some super lean parts in the higher rpm, low load parts of the tune I'm working through, luckily the 'in boost' part of the tune looks pretty safe.  And fast.  Gotta get somebody to go for a ride-along so I can tune while we drive.  Maybe someone in the local Z club.... volunteers???

 

I have to hook up a vacuum gauge to that Ford Air Filter Indicator thing I've got on there too.  I don't know at what point it is 'fully extended' but I'm sure that's not a good sign if it is!  I installed it mainly as a novelty, but if it shows the filter's not adequate, I'll have to....do something...I guess?  Can't imagine running a bigger air filter, I suppose I'll cross that bridge when I get there. IIRC it's off a late 90s/ early 2000s direct injected turbodiesel.  I think even though they're branded Ford they're made by a Donaldson and are marketed as the "Filter Minder".

 

image.png.61d4188d8d966971754920b5acb09ca6.png

 

image.png.bc035b4c766a3dbf9eee17e5b08c255c.png

 

image.png.cb208c31e477dddfd1448ac32cc2317d.png

Link to post
Share on other sites
  • Replies 161
  • Created
  • Last Reply

Top Posters In This Topic

  • 4 months later...

Been driving the car to work a bit lately and working on my tune steadily.  It's getting better running the autotune feature in megasquirt, but i think the old units (like I have) the autotune is really slow.  Would be REALLY helpful to have one person drive, the other person tune.  Oh well.  My dad will be in town next week, maybe we can get out and do a little tuning. 

 

I redid the mount for the clutch slave cylinder to get a more optimal push 'direction'.  No pictures yet. ..:wacko:

 

Also, had a big fuel system issue for a while.  Turns out (2 fuel pumps later!) the 10µ fuel filter I installed was actually intended for low flow hydraulic systems, and had quickly clogged up with tiny bits of who knows what.  Aftermarket filters are IMO mindbogglingly expensive, so I did some digging and came up with what I feel is a good solution with parts that can be picked up at any auto parts store. The pre filter I used is a 140µ wire mesh WIX 33270 (NAPA 3270-$10) with 3/8 in and out hose barb style terminations.  I also replaced my tank to fuel pump line which ran me a under $10 in low pressure line.  I think I bought 4ft and had a little left.  I also used a Unicoil 3/8" to make sure the hose didn't collapse on the 90° bend to the fuel pump. 

 

wix33270.png

 

wix33270.png.0df123eef9c9f0fda2178a7aebb98347.png

 

IMG_1333.JPG

 

The high pressure filter is a kit (PN 910-34190) from Speedway Motors which is cool as it comes with 2x AN-6 to 3/8" quick connect (OEM) style adapters (PN 617-44120).  The filter's rated at 120gph(!) at 60psi and has a 10µ filter element (PN 910-33190).  The kit was $34. You can order just the replacement filter from them as well, but I'll just figure out the OEM number for that too, so I can get it locally if need be.  All went in pretty smoothly and the car actually runs better too.  I wasn't leaning out at the high end (surprisingly) but the pump WAS making weird noises and had a varying fuel pressures. 

 

IMG_1331.JPG

 

Edited by yellowoctupus
no way to place photos while writing post??? Have to do it in 'edit' mode.
Link to post
Share on other sites
  • 1 year later...

I ate up an inner CV a few weeks ago.  Not a single needle bearing was still in the rollers.  It was still somehow driveable, but what a mess.  Here's the PN for the new 'inner assembly' only, as it's getting hard to find full assemblies OEM.  Aftermarket axles normally have the wrong spline count on the center bar so those are not an option either.  This PN is for the non-abs models, which of course suits me fine.  Axle is all back together, and is nice and smooth again.  Explains the nasty clunk I had for a while. 

 

image.png.ebad76f2c68f7c2a973117144c5507e2.png

 

 

Edited by yellowoctupus
Link to post
Share on other sites
  • 2 weeks later...

Another 'clunk worthy' item.  My front diff mount has been holding up pretty well, however I used a somewhat thin walled steel tube when I made it (what I had in the scrap pile at the time...) and it has been bending and compressing the diff bolts into the tube, so there was play there too.  I got a thicker walled tube this time ( blue one) and removed the diff ear rubber bushings and just solid mounted it there. The assembly still has the polyurethane LCA mount bushings to take up vibration etc.  

 

image.png.03a25ded4de6bf7a53c70bacf2fbac42.png

 

image.png.ee0fe516086e66fddfccbdfa6a11a8d8.png

 

image.png.026476cc38edd501d8ceaa00d539770c.png

 

 

 

Link to post
Share on other sites
  • 10 months later...

Yearly update time!  

 

Throw out bearing died in a BIG way a few months ago. 

 

20210321_163740.jpg

 

Since it's somewhat of a colossal pain to get the transmission in and out of this car I decided to get everything else 'permanently' squared away while I'm in there.  New Exedy clutch+ pressure plate, McLeod flywheel, etc.

 

Replaced the throw out bearing guide tube.  Available aftermarket only.  Ebay, etc.

 

20210321_164216.jpg

 

Also, move the shifter back about 3-4" to get it to line up with the center console shifter boot.  That's been a big project in itself.  Lots of fab work, everything's gotta be JUST right to be tight and smooth but not too tight, of course.  (this is the 'original' shifter I made to get it under the center console.  Not ideal, but worked for what...10yrs?)

 

20210410_155251.jpg

 

20210416_164055.jpg

 

20210419_171818.jpg

Almost there. 

 

Also fixing the old heater/head coolant port that's been like that since I bought the car, making stainless fittings with a dvrs/pass side head crossover port to reduce hot cylinders 7/8.  

 

Oh, ALSO also made (the red thing) a bracket to better mount the slave cylinder.  I have a drawing I'll upload later for the masses that are interested. 

 

 

20210417_175347.jpg

 

20210419_165210.jpg

 

20210419_165202.jpg

Edited by yellowoctupus
photo shuffle
Link to post
Share on other sites
  • 3 months later...
  • 2 weeks later...
  • 2 months later...
Quote

No V8 here, but I do have an EDIS ignition module from a v6 ford, and diff from a mustang GT :) Either yet to be installed, but "dude, I got a Ford!" 😜

 

That reminds me of AMC back in the 70s and 80s.  I had an '84 Jeep Cherokee (ok, they were made by AMC at this point, Chrysler wasn't on the scene for them yet).  STOCK it had a 2.8L V6 (Chevrolet), and a Chrysler 304 automatic transmission. At the same time, you could buy a Grand Cherokee which was running a Motorcraft (Ford) Duraspark ignition system.  It was like they were building cars out of everybody else's parts bin. No wonder they got bought out a few years later.  

 

I had a Duraspark ignition box that I ran in my '65 Mustang that had a big shiny AMC sticker plastered on it (as it came out of a Grand Cherokee at the junkyard), I always thought that was a little funny. 

 

On a different note, the Mustang's long gone (sold a few years ago in Hawaii, and for as much time as I spent building that car I do not miss it at all!) but the Z's 'Coming to America'  or at least back to the mainland.  My wife got new orders and now we're on the East coast, in Portsmouth, NH. The car made it back to California on the Matson boat and is theoretically coming cross country at the moment even though I haven't heard anything about it in 11 days... so if anyone sees it come up for sale somewhere let me know :).  If anyone's curious, it cost roughly $900 to get a car from Hawaii to the west coast, and another $1500 to get it cross country.  Not cheap, but cheaper than trying to find a clean shell and start over again I guess.

Link to post
Share on other sites
  • 1 month later...

Well, the Z made it to NH (2weeks ago, this is old news now I guess).  Mostly without harm.  Unfortunately, whoever loaded it on the first truck rolled the ignition back to the lock position which jammed the steering.  So, they loaded it backwards which of course caught air under the rear louvers, causing them to eventually fatigue and snap in half.  The bottom half stayed latched to the hatch, the top half flipped up onto the roof and it rubbed down to the original paint/primer at least.  Good thing it needed another paint job, otherwise I'd be REALLY PO'd.  

 

Additionally, they were supposed to deliver it to my parents house south of Buffalo, NY as I was not expecting to have a house lined up yet, but the driver apparently refused to take his truck down the windy roads to get to their house.  Somehow, the company owner was using the wrong phone number to contact me so the car got delivered to Albany, NY where I think the company is centered.  So, instead of taking it to Buffalo, I convinced him to just deliver it to NH as it was a shorter distance for his driver.  The delay was just long enough that we had a house lined up and it got dropped off in my driveway.  
 

Anyways, after taking the ignition all apart, I found out that I could pull the key back just a tiny bit (1/16"?) and it would unlock fine.   Just a tip as I see it is a common issue on these super high mileage ignitions. 

 

 

Link to post
Share on other sites

It will be neat to see if the 14yr old paint is any good!  (The only paint job it ever got after the factory was back in 2008). My dad used to have the paint locker (ie, an old stand up freezer) heated with a 40W incandescent bulb during the winter but I think he stopped doing that about 10yrs ago, so I'm guessing it's shot now.  Too many thaw/freeze cycles by now.  

 

There's a few other spots on the rockers and one on the passenger's door near the mirror (weird spot for rust...) that need attention first too.  Once I get the welder gassed up I'll see what I can do about welding in some patch panels.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...