Jump to content
HybridZ

LS2/T56/240z BUGS and GREMLINS


Recommended Posts

Now that the install is done, it is time to start a new thread to chronical all the bugs that I will work thru to get car on the road and on the track. Did I mention that this car is FREAKIN FAST?

 

1) Locking rear brakes. This was a "while I was at it." My hydraulic handbrake progressively locks over the first 5 miles that I drive the car. Bleed brakes, problem solved, does it again next day. I've gotten some suggestions from another thread I started. Will chronical my solving of this problem on this thread. I had exchanged the push-rod that connects the brake lever to the master cylinder. Perhaps the new rod is keeping fluid from returning to the reservoir. Will keep you posted.

 

2) MAJOR fuel leak at fuel tank. Before starting the car, I put 7.5 gallons of 93 octane $3.83 gas in the car. It started, no leaks. Drove car for a day and a half of test drives-no leaks. For 2 days, I forgot that I was in a Datsun without the famous fuel stink. Went to gas tank and bought $26 (about 6 gallons) of 93 octane and BINGO, started smelling raw gas on the trip home. Looked under car and fuel is GUSHING under the car. So big of a leak I couldn't wait to get car on jacks and try to find leak (car is really low). Gas is totally running down the curb. Panic syphoned gas into my father-in-law's car (he was unwilling to pay $3.83 a gallon-so he got it for free!) and only drank about half of it. With gas syphoned off, leak stopped. Now time to find the leak. I freaking hate gas tanks, vent lines, filler necks, etc, etc, etc. The last time I thought about selling this car was over the darn fuel tank, arghhhhhh! I'm praying that I forgot to tighten the fuel return line and that when the fuel level went up, it pressurized the line it instead of allowing it to vent to gravity. Please Mr. Takayama, let me just have to tighten a loose AN fitting! The MOST LIKELY location of the leak, and them most challenging, is the access hole that I put in the top of the lower half of the tank for future fuel sump clean-outs. Perhaps it is not water tight inspite of the o-ring. Car is now back in the garage, on jacks, and I am about to go gremlin hunting. My eyes are burning and I'm about to pass out from funes, very dizzy...did I mention that this car is FREAKIN' FAST???

 

Update:

I sprayed talc all over the tank to help me identify the leak, then I dropped the tank. The home-built inspection lid is the culprit. I need some help fixing this. Any 90s 300zx experts out there? The o-ring didn't seal the lid. It leaked almost as if the o-ring wasn't there. Anybody got an experience with replacement and sealing of a 90s zx in-tank fuel pump?

post-5903-017922300 1329975665_thumb.jpg

post-5903-057087800 1329975677_thumb.jpg

post-5903-062992900 1329975687_thumb.jpg

post-5903-078687300 1329975696_thumb.jpg

Edited by RebekahsZ
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...