Jump to content


Photo
- - - - -

82 L28ET lean out top end issue


  • Please log in to reply
22 replies to this topic

#21 stupid_fast

stupid_fast

    Moving Up

  • Members
  • PipPip
  • 35 posts
  • LocationNorth SF bay area, California

Posted 14 June 2015 - 09:09 PM

It was a bad ground.

Verifying the fix.



/thread


83 ZX NA->L28ET


#22 aarang

aarang

    Member

  • Members
  • PipPipPipPip
  • 373 posts
  • LocationCamas, WA

Posted 04 August 2015 - 03:15 PM

Just wondering what ground you found bad and if indeed it is fixed?


280zx-t in progress....

#23 stupid_fast

stupid_fast

    Moving Up

  • Members
  • PipPip
  • 35 posts
  • LocationNorth SF bay area, California

Posted 06 May 2017 - 11:20 AM

Just wondering what ground you found bad and if indeed it is fixed?

Sorry I hadn't checked this thread in a while.

@mods, Necro post reason: found the real solution.

Turns out I was troubleshooting multiple issues with similar effects.
The issue I corrected in 2015 was a bad negative battery terminal, the bolt was tight but it was loose I could wiggle it around. 

I've been rebuilding the drive train on my car over the past year, just got it running and the same issue came back.

I put on a fuel injection tester & monitored the fuel pressure while driving, it was dipping to around 20psi when the issue occurred.

The cause turned out to be a clogged filter screen at the fuel pump!!

I feel a bit silly after all that diagnostic work to find such a simple solution, but at least I verified the rest of my setup and learned something. 

The motor is running very nicely now, after manually re-calibrating the AFM for proper fuel flow. 
 


Edited by stupid_fast, 06 May 2017 - 11:20 AM.

83 ZX NA->L28ET





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users