Jump to content
HybridZ

mldub2

Members
  • Content Count

    35
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

0 Neutral

About mldub2

  • Rank
    Junior Member
  • Birthday 03/25/1985

Profile Information

  • Gender
    Male
  • Location
    san antonio texas
  1. I have some turbo piston with rods on them
  2. I am with you on wiring I also have a 75 but with a turbo motor. I can't get my alt to recharge the battery and my gauges won't light up to.
  3. Need engine bay harness . Let me know ASAP
  4. I don't have a charge light just a 60 amp gauge and that never goes over 0 amp. When I turn on the light it drop down below 0 amps.
  5. I don't know if everything worked before turbo swap. No engine when I got it and it's a new alternator. I will look in the FSM and see what happens.
  6. I just put a l28et in my 75 280z and am using the stock alternator from the 75 (new and tested) and a new voltage regulator. When I start the car it runs off the battery. When I remove the negitive cable from the battery car turns off. I have taken the alternator to the auto parts store2 times. Both times they said it was good. PLEASE ANY HELP.
  7. I have a 75 280z turbo I am using a new 75 alt and a new battery and new voltage regulator. My car starts good and run ok right now as long as my battery is charged once i drive it for a little bit It runs like ****. Then back to charging it again. So I had it tested and they said it's good. What else can it be grounding straps maybe. Any help.
  8. There is and engine in San Antonio tx for sell for 400
  9. need a 75 280z bash board wire harness asap shiped to san antonio tx
  10. I almost move to lake Charles to work on kc-10. But bib not work out
  11. LET ME KNOW HOW MUCH WITH IT SHIPPED TO SAN ANTONIO TX 78254
  12. Ok now i just need the engine bay harness and under the harness under the dash.
×
×
  • Create New...