Jump to content
HybridZ

EatZrib

Members
  • Content Count

    9
  • Donations

    0.00 USD 
  • Joined

  • Last visited

  • Feedback

    0%

Everything posted by EatZrib

  1. It's stuck again. Sprayed a whole lot of wd-40 but still won't free itself at all. I tried adjusting the ebrake cable but nothing happened. Seems like the coiled spring isn't strong enough to pull the cable in order to release the ebrake. Idk. Just my guess.
  2. Thanks folks. I tried it and knocked it with a hammer and it works fine now
  3. when i try to disengage the e-brake the driver rear wheel is stuck. now the linkage wont free itself completely but i always resort to pulling the cable from underneath near the rear driver wheel to free it completely. is there any way i can just fix it without buying anything?
  4. Wondering if this will work people. I'm looking into doing an engine swap soon. Thinking about the s85 engine that's in the E60 BMW m5. That's a v-10 engine!! I've seen a thread here somewhere that some threw in a viper crate motor v-10 in a z. Will it work?
  5. Thanks for all the help people. I'll be using all the info to choose the right rim/size.
  6. The digital gauges are pretty cool. But the speedometer stops increasing after 85mph. I know I'm still accelerating past that but it get annoying not knowing how fast you're really going. Anyone know how to take it off or adjust the settings? Oh it's 2+2 n/a if it helps
  7. Thanks a lot buddy. Will look through this
  8. Hey people I'm new to this whole thing so please take it easy. Anyways, I have a 1983 280zx 2+2 with 17x7 konig's image with a fat spacer.. I want to get new wheels but with a more aggressive look. What's the lowest offset i can go with this car? I want to run basically a stock setup for right now but maybe later on throw on some coilovers. And maybe fender rolling.
×
×
  • Create New...