Jump to content
HybridZ

jjslade

Members
  • Content Count

    24
  • Donations

    0.00 USD 
  • Joined

  • Last visited

  • Feedback

    N/A

Community Reputation

0 Neutral

About jjslade

  • Rank
    Newbie
  • Birthday 01/28/1997

Profile Information

  • Location
    : Portsmouth UK
  • Interests
    Z

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. At the moment i'd say the lowest part is about 3.5" from the floor, i'm not into that stanced look whatsoever, but do like fairly low cars. I'm currently restoring it so I have never driven it, so was just wondering where abouts people had their ride height set.
  2. Here is a video of it running if it helps, idling at about 1000 rpm, and the smoke is quite a bit more white in person
  3. Just seeing how much i can reasonably lower mine, is 2 inches between the chassis rails and floor too low?
  4. So i have done a compression test 1- 100 2- 95 3- 90 4- 95 5-90 6-90 So very low. As i said, it has a brand new head gasket, so could this indicate all the rings are gone? I also had to re grind all new valves in as 10 of them were bent, so perhaps I haven't done it well enough as it was my first time Any other help would be very much appreciated
  5. Haha may be a British term, just means very very rough. I will do a compression test and see what results that yields
  6. Hi there,i've got a 260z with roundtops on, and it idles like a bag of spanners, and emits a ridiculous amount of white smoke out the back. Normally you would think this would be a blown headgasket, but it is a brand new headgasket, torqued down correctly. I have even tried draining all the water from the system and starting it with absolutely no coolant in for a short period, but with the same cloud of white smoke. What else could this be? a warped head maybe, or vacuum leak? Really getting to my wits end with it now.
  7. Hi there, I have a 260z with the following cam, 284 advertised duration....210 at .050 duration with .435 lift on 109 degree LSA, would you guys reccomend the 40 or 45 triple webbers? and also would the stock mechanical fuel pump be adequate? Thanks
  8. Yep they both are hard to raise and fall slowly, have correct oil in dashpot
  9. it wasn’t a full rebuilt i just bought a refurbed set of su’s on ebay and some how the needles were bent. i’ve sprayed started fluid all around so i know there’s no vacuum leak
  10. there’s really a lot of white smoke coming out the back, but i’ve got a brand new head gasket, and just using regular water for coolant temporarily plugs are black and sooted after 1 minute of running
  11. how could i reduce the amount of air going in? i’ve tried spraying started fluid all around the intake & manifold and nothing causes a rise in rpm, should i try with the air cleaner fitted ?
  12. Not sure what needles they are, i just bought a 240z carb rebuild kit on ebay, float level is reccomended to be set at 14-15mm so i set both at 14.5
  13. with this setup current my SU’s are cranked all the way to the top, idle screws set as low as possible, and it’s still idling at 2000rpm and incredibly rich, so i’m thinking when i ordered a carb rebuild kit i bought the wrong needle? could someone please recommend me an appropriate needle for this setup? Kind regards
  14. I'm looking for a bit of stretch but nothing crazy, maybe a 235 or 245 section tyre
×
×
  • Create New...