Jump to content
HybridZ

z31 oil problem after engine revision


Recommended Posts

Hello,

i have bought an 300zx turbo 1987 and I decided to revise the engine completely. Yesterday I tried to start it after it was revised but I had some problems with the oil. When I try to start the engine the oil pump doesn’t deliver oil. The oil light keeps burning and the oil pressure gauge stays on “zero”.
What could be the cause and how can this be solved ?

Link to post
Share on other sites

What exactly did you "revise"? I can think of a number of reasons why your oil gauge reads zero. 

 

If you have no oil running through your engine, or you even suspect you have zero oil pressure, don't start the car. At all, until you are positive you found the issue and verified it. If no oil's running through your engine, it can make quick work of it and let all the lubricated surfaces slap into each other. Not good.

 

So you're going to want to check your oil pressure manually at first, since it's entirely possibly your car isn't getting a good pressure reading. Go to a harbor freight or an autozone and buy/rent an oil pressure test gauge, and screw it into your oil pressure sender. I wouldn't start the car though, at this point, unless someone was watching the gauge.
 

The specs are in the FSM. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...