Jump to content
HybridZ

Darius

Members
  • Content Count

    117
  • Donations

    0.00 USD 
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

2 Neutral

About Darius

  • Rank
    Member

Contact Methods

  • Website URL
    http://darius240z.com

Profile Information

  • Gender
    Not Telling
  • Location
    walnut creek, ca
  1. Just made over 1000whp on my Lt1! Which is more than enough for the car. Hoping for 180+ in the half mile.
  2. Here's some video of my 240z at the shift sector half mile event in Coalinga, Ca April 20th.
  3. I brought my 240z to Santa Clara, Ca for the Sik Industries car and motorcycle stunt show. This was my 1st outing in the Z, ripped a few donuts for the crowd. It was nice to finally get some fun out of the car after 10+yrs of work. http://s120.photobucket.com/albums/o171/dariuskhashabi/sik%20industries%20car%20show/
  4. We'll after going thru all the problems I had at the last shop I was getting the Z dynoed at it's finally back home. I pulled the motor and had it checked out, it needed a rebuild from having too much fuel ran through it. The rings showed some wear and it had some fuel in the oil. So it's all rebuilt now and I'm looking for a good place to tune it. Here's a little video unloading it from my trailer. D
  5. like 8-9 years ago, It did sit for quite a while before it was running.
  6. There's definitely no wildlife living in my exhaust lol. The motor is back out, I'm going to take it back to the place that built it and have them figure out what's going on. The motor still has bone stock lt1 heads and intake. I'm probably going to put a set of afr's on it. Is the lt1 intake worth messing with or should I get a lt4 intake or a hogans?
  7. not sure, it's been so long I can't remember and the machine shop doesn't have any record I'm still running the stock lt1 heads, but since the motor is coming back out I'm going to get some better heads and maybe a hogans intake. Maybe the lifters are bad? Timing is on it's mark, car runs and idles good so the valves are fine. It should be making close to 400rwhp without the blower and close to 700 with it. No I haven't, probably a good start lol.
  8. We'll my 240z has spent the last 6 months or so at a local shop. I originally took it there thinking it's only going to need a tune and I should be good to go. We'll as we all know things never go as planned. Supposedly the Edis box that I had controlling the coil on plug setup wasn't firing correctly and $1500 later I had a new accel system no longer using my crank trigger but a one off dist system running off the cam sensor. We'll that system wasn't compatible with my old gen 1 fast system so out that came and in went a gen 7 sytem. Figuring all that out took this place about 5 months. Now got the car running better and on the dyno it went. Then the new problem came up. The car put down a whopping 400rwhp on 21lbs of boost!! Ya I know!! So they took the blower off and it put down a incredible 198rwhp. Now one thing I noticed when I 1st fired the car up 2 years ago was that there wasn't much air coming out of the exhaust. You guys have seen the old video, the car thumped out air at idle before. The shop I had it at seemed to think the cam timing was off and that was why air wasn't flowing through. We'll the cover was pulled and the cam timing is dead on. Also when this work was being done my guy told me that the intake manifold and intake runners were full of exhaust soot, all the way up to the throttle body!! What the hell could be causing this? This motor was a fresh rebuild although it did sit for 8 years or so before being fired up. Also the motor shouldn't be making 21lbs with the pulley combo I have, maybe like 15-18 at the most. This has to be a head related problem. Cam doesn't look flat, what the hell could be causing this? I'm having a hell of a time getting this car back on the road, it's been over 9 years since the original video was made.
  9. Thanks, it's been a work in progress over the last 15 years.
  10. I want to get it laying patches of rubber everywhere!! Does anyone know someone who can tune the Fast system in nor or so cal?
  11. Thanks, can we get some pics of it on the HRE site? I've had the wheels since 98.
  12. 11 3/4 in the rear and 11 1/4 up front. They were 17x8 before I had them widened to fit the fenders.
  13. I finally picked the car up today from Justin at Samberg Rod and Custom. I'm super excited to have the car back in my posesion again after soo long. It starts, runs, and drives but needs a tune and aligment asap. I can't wait to get the car on a dyno and get it running right, it's gonna be a beast! I'm happy with the way it turned out, sometimes I was in doubt but the body kit ended up looking the way I wanted. I'm sure there will be lots of things to be worked out once I start driving it but that's all the fun stuff. All the pics are full rez, click twice to access the full size of the image. http://s120.photobucket.com/albums/o171/dariuskhashabi/240z%202/
  14. No because air is blowing out of it unless it's closed to which no air would come in.
×
×
  • Create New...