Jump to content

No power after connecting with laptop


Recommended Posts

Help me HybridZ, you're my only hope.


First I have an Megasquirt 1 extra (MSnS 1) v3.0 board.  No relay.  


Before trying to connect MSnS with my laptop it was running rich but working.

I tried to connect to the 9 pin using a 15 pin adaptor and connecting it that way. 

After hooking it up I heard a whistling noise like the injectors emptying and saw the fuel rail pressure drop from 40->0.  

Afterwards I cannot connect to MSnS.  I disconnected the laptop and tried to turnover the engine, no fuel pump noise either.


I thought I might've blew a fuse, but they're all fine, and relays are good too.


I took out the MSnS and visually checked for burns etc, it looks fine.

I've been tracing wiring trying to find an inline fuse I might've missed. 


Has this happened to anyone else?

Any advice on how to proceed?


I guess it's time to buy that stim board.

Link to comment
Share on other sites

I tried to connect to the 9 pin using a 15 pin adaptor and connecting it that way.

Was the 15 pin connector in question on the computer or the MS?


The 15 pin connector on some MegaSquirt versions is an expansion connector that, if used, is meant to be wired to the engine.


The 15 pin connector on laptops is a graphics output connector. Trying to use a MegaSquirt as a graphics display may cause a short circuit.

Link to comment
Share on other sites

The 15 pin connector was on the computer.

I feel like an idiot.


I'm going to get the board tested and hopefully repaired at a local computer place.



Thanks for your help!


If it doesnt work out, I'll hit you guys up for a MS 2 extra.


Do you have an assembled unit for a L28ET?



** update: I talked to my IT guy, and he said that the ozone smell means its fried.  

Edited by tolerate
Link to comment
Share on other sites

Does diyautotune have a repair service? You could go that route.

We can fix ECUs we originally built, but are not set up to work on ECUs bought elsewhere or built from a kit. For those, I'd recommend Peter Florance; he's the guy we send our hardest warranty work to. Here's his website:



Edited by Matt Cramer
Link to comment
Share on other sites

Yes, I'm working on the original.  I just soldered the stim together and plugged it in for power.  All the LEDs were lit up/pulsing.  I will check for fuel and spark tonight.  I originally tried to hook it up b/c I was running too rich, engine kept shutting off. Now i wonder if its a sensor problem.

Link to comment
Share on other sites

Thanks Matt for taking the time to help me, I really appreciate it.

Sorry for being noobish, I don't understand how to upload my msq on this forum, so I made it available on mediafire (its in a zip file).




Car stats:

Rebuilt 28LET 
(reworked head, original pistons, new rings, bearings, honed and dipped block, new gaskets, water pump, oil pump)
MegaSquirt n Spark Extra EFI
Turbonetics (I think) T3/T04B turbocharger 
Intercooler with 2.5" aluminum piping
Griffin aluminum radiator
16" electric fan
SS Braided fuel lines and fittings throughout
Aeromotive Fuel Filter
Russel fuel filter at pump
255LPH Walbro Fuel Pump
MSD Blaster Coil
90 amp Maxima alternator
260z intake manifold (no EGR)
Cold air intake
440cc Supra injectors (flow tested, Dec/13 by witchhunter)
JSK O-ring Fuel Rail
Aeromotive Fuel Pressure Regulator
Innovative Wideband O2 sensor
Autometer boost gage
SS Braided brake lines
60mm Throttle body
Blitz Blowoff valve
Link to comment
Share on other sites

Just wanted to update you guys.  I recharged the battery and swapped the fuel and main relays out and boom, it fired up.  Thanks Matt for the advice changing my ego set, its running a little lean, but I think it'll sort out with new gas and letting it run.  Will go for a test drive after I replace a leaky brake booster.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...