Jump to content


Photo
* * * * * 1 votes

~73 Turbo L28 to N/A RB25 240z Project~


  • Please log in to reply
413 replies to this topic

#41 Domzs

Domzs

    Totally Addicted

  • Members
  • PipPipPipPipPipPip
  • 1328 posts
  • LocationDenton , Texas

Posted 10 May 2013 - 01:18 PM

Great job ! Awesome looking car . :icon10:


 

78 LS1 w/ auto , 83 LS1 w/ T56 , 91 NA . :rockon:

280z sign.

 

Dom .

 


#42 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 15 May 2013 - 05:27 PM

81 ZX close ratio 5spd showed up today. In the process of cleaning it up, might end up painting it if I get really bored haha.

 

IMG_5096_zps5544af56.jpg

 

IMG_5095_zpsf53fefe5.jpg

 

IMG_5097_zpsb0917ad9.jpg


Edited by ~KnuckleDuster~, 24 May 2013 - 06:59 AM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#43 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 23 May 2013 - 05:39 PM

5/22/2013,  the Z came home for the first time. Not under her own power unfortunately...currently in the process of tracking down a no spark problem so the ECU is getting sent to Jim Wolf for a closer inspection.

 

Spent the whole day cleaning the ol' girl up. I removed the ugly yellow fog lights and clear side markers, and did a phase one cleaning job.

 

I was really surprised to see how clean the hatch area was. The paint looked brand new and no signs of rust.

 

IMG_5149_zps37c823b0.jpg

 

 

IMG_5132_zps3360eb6d.jpg

 

IMG_5134_zpsa1ca3ec2.jpg

 

Here's some of the junk..

 

IMG_5136_zps5baeb7fb.jpg

 

IMG_5200_zps2eaed92d.jpg

 

Looking Japanese again..

 

IMG_5141_zps78452b18.jpg


Edited by ~KnuckleDuster~, 28 May 2013 - 06:06 PM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#44 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 24 May 2013 - 02:57 PM

My dad came over and took some pics today, turned out really nice! :icon47:

 

newzfront_zps243a82c3.jpg

 

 

 

IMG_5160_zpsd63924bb.jpg

 

 

 

Here's my other beast from the east...

 

IMG_5167_zps3f6bca4e.jpg


Edited by ~KnuckleDuster~, 30 June 2013 - 11:03 AM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#45 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 26 May 2013 - 12:18 PM

I pulled the driver side carpet up today expecting to see some form of rust but was surprised once again to find it's rust free from what I can see. There was some missing body plugs and bumps from improper jacking.

 

IMG_5172_zps4fe28599.jpg

 

IMG_5173_zpsecd7e5f2.jpg

 

IMG_5174_zps62a22d4b.jpg

 

*Edit*

 

Removed the passenger side carpet today. No rust.

 

IMG_5193_zps04eb2d53.jpg

 

IMG_5195_zpsd814f548.jpg


Edited by ~KnuckleDuster~, 28 May 2013 - 07:24 PM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#46 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 28 May 2013 - 12:42 PM

Looking around for future rusty problems today. Under the cowl looked pretty good. Some light surface rust.

 

IMG_5177_zps6a329464.jpg

 

Looks like the driver door was replaced at some point, good amount of surface rust at the bottom right.

 

IMG_5178_zps8206ca10.jpg

 

Passenger door appears to be untouched. Makes sense..it opens and closes like new.

 

IMG_5190_zps2fcd4620.jpg

 

 

The battery tray area looks like it might be the worst part. Hard to really tell with 3 different layers of paint.

IMG_5191_zps53192fcc.jpg

 

I found a receipt under the carpet from 2010 in San Jose. Seems like typical minor rust from a Northern California Car no?

 

Going to use Por 15 to combat these areas.

 

IMG_5197_zps67079ac9.jpg

 

I've had these military grade Humvee air ducts for awhile now waiting for a purpose..

 

IMG_5184_zpsba9ebe1d.jpg

 

Since the intercooler pipes are taking up the fresh air vent holes I used the lower holes and routed them up to get some fresh air inside.

 

IMG_5185_zps982251c9.jpg

 

IMG_5187_zps9b752e27.jpg


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#47 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 29 May 2013 - 03:30 PM

The battery area didn't turn out as bad as I thought it would. What looked like any rust was mostly old paint and battery acid nastiness.

 

IMG_5206_zps362ed6aa.jpg

 

All cleaned up and 2 coats applied.

 

IMG_5220_zps8ac09d03.jpg

 

IMG_5215_zps6c9ebfb7.jpg

 

Had some left over so I decided to coat the underside of the cowl.

 

IMG_5218_zps58ac873d.jpg

 

Also painted the inspection lids in a semi gloss black to match the under side of the 78 hood. Prior they were red underneath.

 

IMG_5230_zps5eddbe34.jpg


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#48 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 30 May 2013 - 02:56 PM

Just a couple of random shots..

 

IMG_5258_zpsa02044a2.jpg

 

IMG_5247_zps930b3804.jpg

 

IMG_5255_zps1ffe87cd.jpg


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#49 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 12 June 2013 - 02:46 PM

Here's a video of a little walk around. Shes looking a little bare, I've been concentrating on the interior work lately.

 

http://youtu.be/juFBRWZLaMQ


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#50 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 18 June 2013 - 10:58 AM

Replaced the driver side weather striping and installed the rubber door bumpers that were missing.

 

IMG_5360_zps6572f7e1.jpg

 

IMG_5363_zpseaf4867e.jpg

 

 

I've been toying with the idea of using this Trico vacuum powered van for some extra breeze. Going to see if it grows on me. 1920's aftermarket goodies are cool! :icon45:

 

IMG_5370_zps9d2409cb.jpg

 

 

Here's the shift knob. Retro look but with classy redwood burl wood

 

IMG_5273_zpsfc8568e4.jpg

 

 

Current interior picture:

 

IMG_5398_zpsb76f5462.jpg


Edited by ~KnuckleDuster~, 21 June 2013 - 01:05 PM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#51 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 10 July 2013 - 05:32 PM

Got some cool weather to work in today so I decided to black out some more stuff :icon54:

 

Finally got around to putting the new seats in, I didn't think it would make much of a difference but danm are they looking good in there!

 

IMG_5492_zpse1319839.jpg

 

Put the new rear interior pieces together, & installed the rear hatch seal.

 

IMG_5488_zps8d5f130d.jpg

 

IMG_5487_zpse04809dc.jpg

 

IMG_5490_zpsd57bfda0.jpg

 

Changed valve covers, finally got rid of that nasty red thing. Under the cover looked extremely clean..

 

IMG_5480_zps389a8994.jpg

 

IMG_5497_zps68b9c767.jpg


Edited by ~KnuckleDuster~, 10 July 2013 - 05:32 PM.

1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#52 winstonusmc

winstonusmc

    Always Here

  • Donating Members
  • PipPipPipPip
  • 396 posts
  • LocationHavelock, NC

Posted 25 August 2013 - 09:09 PM

I like this car, next time I come there, it will be in my beast. I need to update my build thread.....

'72 240z w/ RB25DE ITB MS3/MS3X

http://forums.hybrid...40z-rb25de-itb/


#53 Domzs

Domzs

    Totally Addicted

  • Members
  • PipPipPipPipPipPip
  • 1328 posts
  • LocationDenton , Texas

Posted 26 August 2013 - 04:51 AM

Looking good . :-D


 

78 LS1 w/ auto , 83 LS1 w/ T56 , 91 NA . :rockon:

280z sign.

 

Dom .

 


#54 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 26 August 2013 - 06:44 AM

I like this car, next time I come there, it will be in my beast. I need to update my build thread.....

Nice! Once I'm running we can take a drive and shoot some pics of the twins :icon10:


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#55 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 28 August 2013 - 04:53 PM

So I was working on the Z today and had the rear hatch open with a box fan blowing inside the car. I was working in the engine bay and began smelling an extremely strong piss odor. I followed my nose and came to the conclusion that it was coming from behind the dash somewhere. I found a few mouse turds and chewed wires before this so I figured there must have been some nesting area I havn't found yet. I looked under the dash all over and didn't see anything that could produce such a hanus whiff of urine. I decided to remove the a/c condensor figuring that there was nastiness on the top of it. Plus I wasn't going to ever use a/c and weight reduction is beneficial and free..

 

Well I pulled it out, weighed about ten pounds.

 

a052d1dc-903b-4e71-a42b-af4b4445c442_zps

 

IMG_5176_zps9dfe438a.jpg

 

Oh wait whats this? Could this be where the horrible stench is coming from?

IMG_5177_zps989d70d0.jpg

 

Judging by evidence found at the crime scene the suspect moved in sometime in 2008. I'm really glad I found this instead of writing it off as old car smell.

 

IMG_5178_zps4eb3958a.jpg


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#56 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 01 September 2013 - 11:17 AM

Finally got the car running today! Apparently I had a bad coil igniter and fried ecu. Replaced them and fired right up. Just need to get it tuned up now and hopefully Ill have some videos and pictures up soon. Big thanks to winstonusmc for helping me with my wiring mess.


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#57 winstonusmc

winstonusmc

    Always Here

  • Donating Members
  • PipPipPipPip
  • 396 posts
  • LocationHavelock, NC

Posted 02 September 2013 - 07:41 AM

I just wondrr if the wiring had anything to do with the faulty ECU or ignitor. Now you have a more reliable wiring job with fuses.

'72 240z w/ RB25DE ITB MS3/MS3X

http://forums.hybrid...40z-rb25de-itb/


#58 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 04 September 2013 - 12:43 PM

Waiting on a new AFM & coolant temp sensor that will hopefully get the old girl running smooth. Currently in the process of re designing the intercooler set up. I'll be using an IC with both end tanks mounted on one end so I can run very short pipes through the driver side frame holes. Should decrease turbo lag & heat soak. It will also look a hell of a lot cleaner and enable me to use the stock fan if I so desire.

 

KGrHqJHJEMFG5mZd8bBRwh0nOc160_57_zps3f0b


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#59 ~KnuckleDuster~

~KnuckleDuster~

    Member

  • Donating Members
  • PipPipPipPipPip
  • 614 posts
  • LocationSoCal

Posted 05 September 2013 - 07:11 PM

Got the turbo AFM today. Looks a little different than the previous one :willy_nil  I'm shocked at how this this was even drivable before.

 

IMG_5654_zps4d6c3dd2.jpg

 

Went to Lowes and found a fitting for my temp sensor.

 

IMG_5662_zps8d166592.jpg

 

IMG_5664_zps5dc73e5b.jpg

 

Also been cleaning up the wiring some more. Starting to look decent under the hood finally.

 

IMG_5666_zpsd9a2bb31.jpg


1973 240z _Click Here_     GoKart -   Click Here

        

 

 


#60 winstonusmc

winstonusmc

    Always Here

  • Donating Members
  • PipPipPipPip
  • 396 posts
  • LocationHavelock, NC

Posted 07 September 2013 - 09:33 PM

Just needs to move the wire from the one side to the other on the temp sensor. Looks good.

'72 240z w/ RB25DE ITB MS3/MS3X

http://forums.hybrid...40z-rb25de-itb/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users