Jump to content
HybridZ
rayaapp2

260Z + RB25DET S2 motor = badazz 260ZR and some ?'s

How helpful is this thread, ,  

14 members have voted

  1. 1. How helpful is this thread, ,

    • Helpfull
      18
    • Full of $hiznizal
      7


Recommended Posts

Hello all,

 

I bought my car along time ago with this swap in mind. Ive finally gotten around to it. So Im getting hip deep in this thing literally.. lol

 

I own my own web site / server at home. So I have a link for ya'll

Here is my 260Z project.

http://www.datsunmotorsports.webs.com/1974%20260z.htm

There are currently 4 pages as of this thread starting. There will be more shortly.

 

I have posted in a few other threads already with info and questions.

 

Some things I would like to add.

260Z cars require that you CUT the transmission mount flanges off the car before you shove that huge transmission in there. Otherwise you WILL damage the reverse switch... opps... possibly the VSS too if you care to keep it. I also noted the VSS is mounted on the passenger side.

 

My Question:

IF I choose to use the cable drive in the other link my stock cable looks to short...Anyone get this to work and have some instruction? Like run it over the top or what?

 

Any US side radiator help? Mike Rowe has sourced Radiators from China to Australia... It seems to me that we should be able to source a radiator here. Summit or Jegs

Ill add more later.

 

ALSO I wanted to note that JHOT rocks. I had some problems with the shipping company and was prepping up to take on their claims department as I documented everything. They are sending me the replacements for the broken parts and taking care of the claim... AND THEY WERE NOT EXPENSIVE!!!! Here is a link of sellers and ratings

http://forums.nicoclub.com/zerothread?id=115184

 

I will be posting back and putting up all the links I used to do this... all but Chris Rummels sticky as that is right up top where it belongs.

 

I ordered the LAST set of Rick Wongs engine brackets today as well.

I ordered those really cheap engine anchors as well to try them... I think it cost me like 10bucks for them so no big loss. I also noted that these anchors that I will get a link for later require you to drill the cross member out to make them fit in the bolt hole. I will have more info obviously when my mounts arrive.

I replaced the timing belt and the main tensioner. Thanks to Nismo of Seattle

I replaced the oil pan and pickup thanks to Erics Performance... though it was a little spendy

I still need a clutch... I am having problems sourcing a OE one.

I have a few intercoolers around my garage... Im not set on any of them.

- NPR intercooler

- R33 the one that matches the engine

- 88 Toyota Supra Turbo Intercooler... smaller size piping so might just be out of the question.

- Mishimoto Intercooler with 2.5" inlet outlet... I will probably pass.

Derick at Lethal MotorSports has or can get RB parts as well. He will have excellent pricing for the most part. I haven't made any purchases through them yet, but they come highly recommended by Jhot and I liked his prices.

I have both the OE R33 drivelines and a few OE 260/240 Z drivelines and will be taking them to a local driveshaft shop. I have quotes from 2 places so far. The most expensive one is 250 bucks and that is worst case scenario with busted u-joints... and mine are good for sure. I will be reporting back with cost/time/quality when I choose a place. That should help out anyone local to Sacto.

 

I will be adding a TON of info to this post.

 

 

Thanks for any additions

Ray

Share this post


Link to post
Share on other sites

ummm. They were the bumpers that came on the car from the factory, the production date is 9/74 so technically its a late car with early bumpers... but Ive owned a 3/74 that had the early bumpers as well. My only explanation for the production date was the fact that they had multiple factories pumping these babies out and mine happened to come from a factory that was putting cars together with the parts they still had around before they moved on to the next production. Im only guessing of course, but its the only logical reason for the bumpers. Im the Second owner of the car. The first owner replaced the engine and I actually have all the paperwork for all the repairs made since 1976 including 5 of the last smog certificates... I dont think one general rule for production dates will fly for this one. I say "were" because both bumpers are now sitting in a pile of bumpers in my back yard.

Share this post


Link to post
Share on other sites

Rick Wong / Infinity Machining Motor Mount Thread:

http://forums.hybridz.org/showthread.php?t=98448&highlight=rick+wong

 

Mounts are for use with 1986-87 Toyota Supra Turbo isolators, but apparently these can be supplemented with the ones in this thread which are about 3/8" shorter.

http://forums.hybridz.org/showthread.php?t=103170

I just purchased a set of these shorter mounts and noticed that they have a 1/2" shank for bolt studs. So the holes on the S30 cross member will have to be resized for these mounts. I will also have to make another run to the hardware store for some nylock nuts and washers to match these mounts.

 

 

I bought a 36" Spectre universal throttle cable today and installed a L bracket using the 2 holes on the bulk head that use to be for the lever linkage. Pics will be on my website shortly. I also had to purchase a 3USD kit with the cable stop cylinders for the TB side of the cable. I ended up drilling the cable hole on the cylinder out to fit the universal cable and then since the cylinder was 3/8" SAE I had to ream out the TB so the cylinder would squeeze in there properly, but it all works great now and 36" is the perfect length as I thought I would need at least 40"...

 

I will be getting back to my wiring tomorrow I believe. I have done almost everything I can with the parts I have. I still need the mounts to arrive and then I can start fabbing up the cross member for the transmission, and I can measure the driveline length. Once thats all squared away I can finally get a radiator in and the proper hoses and then the intercooler piping can be routed. The NPR intercooler I have makes the most sense to use as it fits the best campared to the others.

 

Some progress: LARGE RAW PICS

http://www.datsunmotorsports.selfip.com/Ray%27s%20new%20Pictures%2007-08/DATSUNS/My%20260z/9-74/My%20RB25DET/P1000728.JPG

 

http://www.datsunmotorsports.selfip.com/Ray%27s%20new%20Pictures%2007-08/DATSUNS/My%20260z/9-74/My%20RB25DET/P1000726.JPG

 

http://www.datsunmotorsports.selfip.com/Ray%27s%20new%20Pictures%2007-08/DATSUNS/My%20260z/9-74/My%20RB25DET/P1000724.JPG

Share this post


Link to post
Share on other sites

Sounds like your off to an awesome start. I found the only reason you have to chop the transmission tunnel, in my case early 240z, was to move the ears back a bit. Other than that it fit right in. Also many hot rod radiators will fit in the Z. I believe it is a chev style, with the input and out on the right hand side. As well I wouldn't worry about VSS, it just is used for the speed cut and a digital speedo, if your using one. If you haven't bought your cable setup for your speedo I would reccomend going digital. The autometer ones can be calibrated for any rearend/gearing combo's so it is really nice if you switch.

 

 

 

Good luck !

 

Chris

Share this post


Link to post
Share on other sites

I think when my mechanic did the swap, he used a Nissan 240SX Throttle Cable. Also, for the radiator I used a PRC Dual Pass Aluminum Radiator...Here's a picture of the radiator.

 

RBZ_Radiator.jpg

 

Also, check out www.daftinnovations.com go to the myspace page and look at the photo album. If you look at random jobs, you'll see a Z with a RB25 so you can get an idea how he ran the intercooler pipes and intercooler...the guy used a Freddy intake manifold though...You can see what it would look like if you look at the RB20 Swaps. Hope this helps you with your project

Share this post


Link to post
Share on other sites

I dropped both the S30 drive line and the R33 drive line off at a local shop. Drive Line Service of Sacramento. They quoted me out at half the cost that Ive seen around here and Nicoclub.com. That quote included machining the R33 slip yoke to accept a serviceable U-joint and replacing both U-joints with a more standard serviceable Spicer part, and obviously putting it together and having it balanced out.

 

Anyone in the area that is doing this swap could probably use that info.

 

Ray

Share this post


Link to post
Share on other sites

Anyone else use the "cheap" 5usd mounts with Rick Wongs adapters? I got the engine in and I cant get those mounts straight. The offset is wrong. They arent totally straight and Im a little OCD about such things so its bugging me though I know those are generic mounts and it wont REALLY matter as long as the engine is straight in there.

 

Thanks

Share this post


Link to post
Share on other sites

I have the hood back on and a ton of pictures to post.

I started to fab up the transmission cross member. Its a little harder than it looks. Ive fabbed as a living before to so this is nothing new to me. I think I may have to make a run out to the steel yard to get what I need to build the member.

 

Im still playin chase the wire loom around as well. I ran out of time and had to step away from the wire harness for a few days and then continued and as usual I marked everything and still somehow messed it up. The start signal is definately powered up while the car is in the run position. And the fuel pump signal isnt working so I need to trace the wires back out and see where I rushed it and make sure I made the corrections and note them on my writeup.

 

I paid 225USD for my Hybrid Driveshaft and picked it up yesterday. They did a great job.

 

 

Ray

Share this post


Link to post
Share on other sites

I briefly started the RB to make sure everything is functioning. I had 1 vacuum leak on the manifold I had forgot about at this time. I started the engine and it stumbled until I gave it a little throttle. So I found the vacuum leak and plugged it with the engine running. Then the engine started to run rich... So at that point I turned the engine off and I made sure I had not connected the start signal wire to the wrong source. It was correct. I havent been able to get much farther, but I suspect the engine starting with a vacuum leak throws the A/F ratio and I just need to restart the engine with no vacuum leak... Otherwise I have a serious problem to track down to make sure I can fix soon.

 

UPDATE on other questions

 

1. IF I choose to use the cable drive in the other link my stock cable looks to short...Anyone get this to work and have some instruction? Like run it over the top or what?

The original cable is plenty long to reach, simply run it over the top of the transmission and down to the drive.

 

2. Any US side radiator help? Mike Rowe has sourced Radiators from China to Australia... It seems to me that we should be able to source a radiator here. Summit or Jegs

A few answers, but Im still looking. Im trying to find a $100 or less radiator as a solution. I believe that a 16X24 double pass aluminum radiator will do the trick. Ive been digging trough radiator applications and so far only one has come close. 96 Nissan Pickup. Its single pass and has a built in trans cooler as well. So Im thinking its cooling potential is below what I will need esp in a hard run.

 

3. I still cannot source a friction disc for the clutch. any help?

 

4. Anyone else use the "cheap" 5usd mounts with Rick Wongs adapters? I got the engine in and I cant get those mounts straight. The offset is wrong. They arent totally straight and Im a little OCD about such things so its bugging me though I know those are generic mounts and it wont REALLY matter as long as the engine is straight in there. anyone?

 

 

 

NOTE:

 

Rick Wong says that he will make more mounts if ppl still want them. So if you want a set of these mounts I would contact Rick Wong about getting on a list. These mounts are worth the $$$. Very nice quality.

http://forums.hybridz.org/showthread.php?t=98448&highlight=infinity

Share this post


Link to post
Share on other sites

Car started and moved under its own power today. I checked my wiring and it isnt a problem, Ive double checked all the connections. The car still runs a little to rich and I havent been able to figure it out yet. I suspect a vacuum leak or something stupid. The car is wicked fast. Snap your neck back fast. I didnt expect it to be that quick.

 

I have some part numbers to add later.

I am using the 200sx radiator mentioned in another post.

radiator - 82-83 200sx m/t 2.2L NAPZ

Radiator hoses ... will post em later.

 

ALMOST forgot, I have an interesting noise going on with the transmission.

If your idling everything is good and there is no noise. Rev it up in neutral and still no problem.

Push the clutch in, in any gear or neutral and there is a weird noise. Its like the sound you get when you grind gears without the clutch only a lot softer. If you put the transmission in gear and let the clutch out the noise goes away. So it only happens when the clutch is depressed. My first guess was throw out bearing, but that is definitely wrong as it would be the opposite. My guess is that the friction disc has a problem as it is free spinning at this time.

Share this post


Link to post
Share on other sites

MY TACH WORKS!!!!

 

HEI ignition unit works and the tach reads correctly!!!

 

I extrapolated from a MSNS diagram

8239mss_schematic.jpg

 

I should make them for like 30USD and sell them for 50USD and make a killing since MSD sells them for like 120USD. OR I could just tell you how to make your own.

 

I seriously built this thing from random parts laying around.

tach%20adapter.JPG

Mike Rowe's post about a tach adapter on Chris R.'s wiring thread helped me finish it. I dont have a bunch of technical details like I said it was thrown together using random parts in my garage. A light bulb from the glove box of a 95 Q45, a 1985 Chevy HEI unit, and a random 4 pin Nissan Relay from a 95 Q45.

Share this post


Link to post
Share on other sites

So far with me doing most of(pretty much ALL) the work I am sitting just over 3300USD. I expect to spend 3500USD before Im ready to call it a daily driver. This is all in parts alone and doesnt even take into account the wearables such as cutting discs, welding wire, solder, a brand new soldering iron cause I lost mine, shrink tube, electrical tape, and all the random parts I had laying around to build the harness. I spent alot less than most ppl on this swap so far cause I know people and I searched out my connections for the best prices. In the end I would expect someone else doing this swap to spend around 4500USD+ and not be complete. This response is to all the posts on this forum that I ran across stating what they thought this swap would cost on average. So here is another post confirming that.

 

Here is a quick breakdown on my expenditures so far... and its not even complete. if it says 0 that means I already had it or it cost me nothing. If it is blank I need to find a receipt.

 

 

Jhot --------------------------------1632.00 + S329---$1961

RB series Rear Sump Oil Pan ---------------------------$295

RB Series oil pickup -----------------------------------$0

Intercooler--------------------------------------------$0

Intercooler piping--------------------------------------$0

throttle cable -----------------------------------------$50.69

RB 25 Timing Belt--------------------------------------$34

RB 25 Timing Belt Tensioner and spring------------------$36

Oil 5W30 Royal Purple XPR------------------------------$51

Oil fitler-----------------------------------------------$0

gear oil------------------------------------------------$20.97

Nissan Rad Fluid for aluminum engines-------------------$0

Radiator hosespar-------------------------------------$30.83

fuel pump----------------------------------------------$0

Fuel filter----------------------------------------------$11.06

Fuel line 8mm------------------------------------------$18.87

tubo timer---------------------------------------------$on hold

mounts------------------------------------------------$268 rick wong

Gell Cell Batt-------------------------------------------$139.69

Batt cables--------------------------------------------$0

clutch Friction Disc-------------------------------------$0

Cable Drive--------------------------------------------$46.44

Driveline-----------------------------------------------$225.00

Rubber isolator mounts---------------------------------$10

Radiator 200sx 82 pnp----------------------------------$71.32

Radiator Cap-------------------------------------------$8

MAF filter adpater--------------------------------------$14

Air Filter-----------------------------------------------$0

Temp gauge sending unit-------------------------------$36.06

 

 

 

-----------------------------------------------------$3328.68

 

 

 

 

Also NOTE:

25080-89903 Temperature Sending Unit is confirmed to work with the S30 Gauge. I

Share this post


Link to post
Share on other sites

So I needed to check my timing today.

I have a miss when at load that I could not account for.

I wanted to put the car up on the power dyno to get a base line to work up from in the future, but because of the miss I passed on it today. Instead I tricked the Snap On Ethos into thinking I had a 94 300ZX TT so I could check for codes and do a general diagnosis. The car came up clean, but the base timing was at 10* BTC. So I disconnected the TPS and moved the CAS until I could read 15* BTC. The miss that before was at top end only, became apparent at off idle low load. At this point we had access to a smog dyno. So we put the car up on the smog dyno and ended up doing a 5 gas analysis. O2 was up a bit, but everything looked normal. So, we backed off the timing to 5* BTC for the time being to try and compensate and prevent any possible damage. Just trying to play it safe.

 

My final determination: 85K miles aka 120K Km equals spark plug replacement time for RB. I pulled all the plugs and the platinum tips on the electrodes were all wore off. So I need to stop by and pick some new ones up at the parts store. Ive got a post about that already though.

 

I was setting my timing and thats what this post is about. I dont understand this completely so this is my best guess as to what I was seeing.

 

Moving the CAS with the engine off will do nothing at all...

Moving the CAS with the engine running will not set timing.

Moving the CAS with the engine running and the TPS unplugged will adjust timing.

 

So if the timing is far off and your CAS is clocked one way or the other you can plug the TPS back in and turn off the car so you can reposition the CAS to the Center. The Center should be 15*.

 

 

Still looking for an answer to the clutch situation

30100-21U01 looks to be the part number Im after and Nissan of Elk Grove is looking it up for me, but they are lagging. Ive been trying to find a replacement stateside. Ive seen some reference to 300zx clutches. Id really rather not pull my trans back out just to measure the clutch. Im betting someone has done the research and has the answer somewhere. Im pretty set on finding a Nissan OE part rather than deal with an aftermarket clutch and all the problems that everyone keeps reporting back with on the net.

Share this post


Link to post
Share on other sites

Since Ive been busy making other posts here they are to just add to the completeness of my build thread

 

Spark Plug Thread http://forums.hybridz.org/showthread.php?t=142787

 

COP (coil over plug) Replacement / Missfire / arching issues http://forums.nicoclub.com/zerothread/393935-s2-rb25det-cop-replacement

Share this post


Link to post
Share on other sites

I purchased a set of "used" coils from Raw Brokerage and replaced the arching coils on my car. The car runs great now. Ive been driving it for the past 2 weeks with no problems... well at least no drive train problems. My Rainex windshield wipers are not clipping on correctly and its raining a lot around here.

 

Im pushing to get my car on the dyno. Im told that Friday the 6th should be a good day. We will see. The SAFC is in place and I wish to tune the car on the dyno.

 

 

The next subject I have become interested in is RB26 cams. I understand the RB26 has solid adjustable lifters where my 25 head has hydraulic lifters. The RB25 also has VVT and the 26 doesn't. I am very curious what the specs are for the 25 and 26 cams. The 26 makes a gob more HP than the 25 did off the showroom floor. There are some major differences in the 2 engines, but none that add up to "gobs" in my opinion. The cams must be the difference. Im unsure of the exact HP difference between the two engines but low est are 250hp for the 25 and 280 for the 26.

Are the cams interchangable?

Anyone have the specs for the cams?

Is there any basis for my speculations?

 

 

Thanks guys

Share this post


Link to post
Share on other sites

100 octane is my friend...

 

BTW I was mistaken about the timing on my car.

 

I set it correctly after using an inductive timing light and a plug wire.

The S2 engine has a combined TPS TVS setup and the ECU only uses the TPS on the S2 where as the S1 uses both inputs. So when timing the S2 you dont do anything to the TPS. simply move the CAS until the timing light indicates 15*. I wish I could edit my original post and change this info.

 

Hope this helps

Share this post


Link to post
Share on other sites

I have yet to this date... 4 months deep, been able to get on a dyno for a base line.

 

I have tackled the leaky sparks from the coils

I have concord the stock rubber turbo inlet hose that tried to go through my turbo

and I have come out victorious.

 

I had to hand fab an aluminum intake for the turbo and mount a new filter. My K&N filter collapsed on in itself. I literally filed an 2.5"-3" adapter to accept the BOV recirc pipe. So Ive added My SAFC II to the car and im running that for now as if it wasnt there. So its just a monitor. I also installed my A:F gauge today. I still want to get a Boost gauge, but that can wait.

 

Things are going well for the car and me.

 

Its very fun to drive.

 

I have to wait my turn to get it up on the dyno and hope there is time, so there is no telling when i will be able to get it done. That sounds pretty bleak, but itll happen. Basically I have to wait until the time is right if I want to do it for free.

 

In the mean time Ive made some new problems. Hard launching has blown out my KYB GR2 rear shocks... They are 3 years old or so. I also bought the parts to build the new trans mount and tuck my exhaust up better so I can lower the car back down. My plan is to if things fall through this weekend, put it all together and maybe even get to the replacing the rear shocks with KYB 4 way adjustables.

 

Ray

Share this post


Link to post
Share on other sites
Guest rb240

The R32 RB26DETT cams are not equipped with VVT, I dont think the later ones are either. The 26 cams are "adjustable" but only through a labor intensive shimming process. The reason the RB26 has solid lifters is because of the aggressive ramp angle on the cams. They are too steep for hydraulic lifters. You could put hydraulic lifters beneath them, but they would likely leak down and result in reduced lift/duration and consequently lower power.

Share this post


Link to post
Share on other sites

Well Ive worked out most of my issues. The car is running pretty good. I still have a hickup hiding up past 75% throttle and over 5500rpm. I have to get the ignition and fuel systems on a oscope to determine what is going on as it doesnt show up on the A:F meter.

 

Ive been using the BlaZt Nissan Data Scan software. Its pretty cool. So to add to the ignition timing setting, I used the Nissan Data Scan software to put make put the ignition into an active test so I could set it. Basically you need to use this or the Nissan Consult to set the timing CORRECTLY. Once the ignition has been set as active you can run "active" tests aka set the timing. Unlike scan tools where you get processed data Nissan Data scan and Consult both give you the raw Ignition timing. I confirmed it with an inductive timing light on a piece of spark plug wire to the number one cylinder. I have the car at 15*.

 

I re-did up my transmission mount.

I had the car up in the air to R&R the rear brakes. Try to restain yourself about the exhaust welds... I ran out of Argon.

P1010078.JPG

 

P1010199.JPG

 

P1010198.JPG

Share this post


Link to post
Share on other sites

Its been a while since Ive made an update.

 

I have purchased several things in the past 4 months.

 

I resurfaced my flywheel with Cascar for $35

Exedy Clutch from PDQ transmissions in Sac ~$350

SS Performance Coils from Raw Brokerage ~$400+

Nismo Fuel Pressure Regulator from Tidus Nissan aka NismoParts.com $118

Bosch 300LPH Fuel pump from 034MotorSports $200

1976 280Z Fuel Tank with -8 AN pickup from StealthZ $50

APEXi Turbo Timer new from ebay $80

NGK copper plugs @ .030"

 

I found that the Pilot Bearing and the Throw Out Bearing could be used from the L series setup. If it makes a difference the pilot bearing and throw out bearing where from a clutch kit for my 83 280zx turbo.

 

The car is driving great!

 

I also started to upgrade the brakes.

84 Toyota 4 piston calipers installed

R32 master cylinder and booster waiting to get installed.

280zx rear calipers/rotors waiting to get installed.

need to buy new brakes lines and rear caliper brackets

 

 

I have also been building a new intake manifold.

I purchased a Freddy manifold. It arrived Polished after I ordered the Raw Cast. So that has been a set back.

I have a modified Q45 90mm throttle body. I purchased a few silicone couplers for the IC from 034MotorSports. 1 3.5" 45* coupler, 1 3.5" T tube with 1.25" T for air regulator/IAC, 1 3.5" to 3" 90* coupler, 1 3" to 2.5" 90* coupler. I have been doing trade work with 034MotorSports, so Ive only paid about $120 for all the pipe an couplers so far. It would have been $30 ea plus the piping @ $50-$60. Ive got the polished Freddy for sale. Hopefully someone will pick it up. I will turn around and purchase the raw cast one or just give in and buy the Greddy.

Ray

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×