Jump to content
HybridZ

Crazy Signal Issues


Recommended Posts

Hey All...

 

Just got my Z running after a full rebuild.

 

20140406_182816.jpg

 

:)

Now I'm working out all of the electrical gremlins...

 

I have a crazy directional signal issue that is making my insane.

 

Here's the breakdown:

 

When I use the right turn signal everything works.

 

rightturn.jpg

 

 

When I use the left signal, the rear doesn't work.

 

leftturn.jpg

 

But when I use the hazards, everything works except the front right:

 

hazards.jpg

 

 

How is this even possible?

the problem is that its not 100% consistent.

It has been the last 10 times or so I tried it so that's why I'm posting now.

 

I just replaced the front left bulb because it wasn't working and I swear that the rear worked at the time...

 

Any ideas??

 

Link to comment
Share on other sites

Would the switch cause lights to work at some times and not others?   Yes

 

 

 

Do the following:

 

  • Google "240Z turn signal switch repair"  There are many blogs that cover this problem.
  • Search HybridZ for the same topic. I know there are many threads on this subject detailing the repair process.
  • If the HybridZ search function does not work then do  another Google search like this:

           Site: hybridz.org "240Z turn signal switch repair"

 

There is also a guy named Dave on HybridZ and at ClassicZcars.com  who used to offer a repair service.

 

Tip: buy a few turn signal and headlight combination switches and learn how to repair them. Just swap in the repaired switch (s) and 90% of the time it fixes the problem.

Edited by Miles
Link to comment
Share on other sites

Heres some more info on it too - http://www.classiczcars.com/forums/electrical-s30/23325-rebuilt-my-combination-switch-today.html

 

A good upgrade is the parking lights and headlight relays from MSA, made by Dave in that thread.  - http://www.thezstore.com/page/TZS/PROD/LNP1/12-4652

 

He custom made both for my 280Z as well. 

Link to comment
Share on other sites

I had the passenger's front turn signal go MIA even after cleaning the switch contacts. It would work just fine when exercising the switch manually, but not work from the lever.

 

After some serious troubleshooting, I found that culprit was the nylon part that couples the rotary action of the lever to the linear action of the switch. Over the years, the nylon part had shrunk. This is not uncommon with nylon as it has some affinity to water. As I worked the turn signal lever, I could see the nylon part racking. If I squared the part up with a fine bladed screwdriver, the MIA lamp began to flash as it should.

 

The fix was simple enough, I scrounged a washer to shim the extra space between the nylon part and the switch. I think I ended up selecting one about .050" thick. Put back together the turn signal lever feels like new with a much snappier action. 

Link to comment
Share on other sites

The turn signals and hazards are two different issues and most likely both switches are the culprit.  if you read the wiring diagram, you'll see that the hazard operates the lights without going through the turn signal switch.

 

The 240z turn signal switch has 4 contacts and 4 wires, one for each corner.  It appears that the contact or wire for the left rear is the culprit.  The contact could have a lot of corrosion which is causing a large voltage drop and preventing the light from illuminating, or else it could be the wire coming from the contact to the plug under the cover.

 

The hazard switch operates the four lights independently of the switch, so if one light is out but it works when the turn signals are used, then it could be the hazard switch or the wire coming from the switch.

Link to comment
Share on other sites

Excellent.

DJ Warner, I noticed with my multimeter that everything is working normally with the switch removed from the lever.

I will try the washer idea. Thanks for that. Sort of thing would take me days to figure out. Much appreciated.

 

KTM, Thanks for pointing out that the hazards operate off of a seperate four contact switch. I heard the relay under the passenger side dash and suspected as much.

That whole circuit will go under review after I am done with this switch.

 

Will post my results after the weekend.

 

 

Heres some more info on it too - http://www.classiczcars.com/forums/electrical-s30/23325-rebuilt-my-combination-switch-today.html

 

A good upgrade is the parking lights and headlight relays from MSA, made by Dave in that thread.  - http://www.thezstore.com/page/TZS/PROD/LNP1/12-4652

 

He custom made both for my 280Z as well. 

 

 

I read up a bit on that but didn't find any info about whether or not it has any impact on the voltage drop when the lights are flashing. I can hear the difference in my fuel pump when the lights blink... Common sense would tell me that it would since it is lowering the amount of voltage used for the operation of the lights, but again I am just now learning about how electricity works in a system like this.

Link to comment
Share on other sites

  • 2 weeks later...

My 72z had a problem just very similar to yours, I looked at the schematic wiring diagram to analyze the problem and it did not make any sense.  Finally I just decided to clean the turn signal contacts and that solved the problem.  Apparently many lines go through the turn signal switch that is not apparent in the schematic.  Another thing you can do is just swing the switch between left and right turn signaling many times at once until the switch contacts are cleaned in that manner.  This is a lot easier than taking it apart.  It worked for me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...