Jump to content
HybridZ

stony

Super Moderators
  • Content Count

    4348
  • Donations

    20.00 USD 
  • Joined

  • Last visited

  • Days Won

    5
  • Feedback

    0%

Posts posted by stony


  1. Hello HybridZ gang, Just wanted to drop a few Picks of the Z and what i have been up to. 

     

    last couple of years were kinda rough and the LS swap wasn't going well. had lots of issues and blew many "junkyard" motors until i figured out what my issues were. (don't ziptie plug wires together haha )

     

    At any rate ended last year with a trip to Idaho for no prep kings and had lots of fun. ended up racing Larry Larsen in his caddy and got my ass handed to me but it was still fun. 

     

    This year will have several other races to go to including another NPK race in idaho. Gonna do small tire this time ;> 

     

    Hope your all making headway on your projects.... still getting inquiries about rb swapping haha. will continue to answer as much as i can but alot of new options out there then what i did with mine. 

     

    Good luck all. and thanks for all the cudo's over the years. 

    FB_IMG_1562670493954.jpg

    FB_IMG_1562670485248.jpg

    FB_IMG_1562670478328.jpg

    20190713_190523.jpg

    FB_IMG_1563195461528.jpg

    FB_IMG_1563079823288.jpg

    FB_IMG_1563079814789.jpg

    FB_IMG_1563079809238.jpg

    FB_IMG_1562673354513.jpg

    FB_IMG_1562670533043.jpg

    FB_IMG_1562673347744.jpg

    FB_IMG_1562670523445.jpg

    FB_IMG_1562670510517.jpg

    FB_IMG_1562670516015.jpg


  2. Yes $300... i put 12k into bolt ons but my long block i just installed was 300. As far as prep... i pulled the pistons and regapped factory rings to 30 thou. Installed a cam, lifters, pushrods and oil pump. Car is making over 900 to crank. I followed all advice on internet on how to make them live except rpm. Was shifting at 7k and running it out the topat 6800 and rpm is what claimed that motor.


  3. Well after a lot of hammering on the first motor it developed a knock that I thought for sure was a rod. tore the motor down and could find anything. bearings were good, checked flex plate, tore trans down and nothing. found another 300 block and prepped it. bolted all my stuff to it and it started first try ;>

     

    Took it out to the track after only 1 trip around the block and it ran a 9.28 at 148 MPH!!! damn I love this junkyard motor thing ;>


  4. I have a set of toggle switches wired in now for headlights and turn signals. I want to wire those into the stock combo switch. Need to know what wires go where.

     

     

    3 stand alone large gauge wires. I THINK I HAVE THESE RIGHT BUT LET ME KNOW IF THEY ARE WRONG

     

    1. R  = BATTERY POWER

    2. B = GROUND

    3. WR = SWITCH 12V

     

    6 pin plug

    1. RW =

    2. RB =

    3. GR =

    4. w =

    5. GB x 2 =

     

    9 pin plug

     

    1. GW =

    2. GL =

    3. LY =

    4. YL =

    5. L =

    6. LW =

    7. YB =

    8. LY =

    9. LR =

     

     

    post-71-0-10244800-1469904284_thumb.jpg

    post-71-0-72485100-1469904285_thumb.jpg

×
×
  • Create New...