Jump to content
HybridZ
Sign in to follow this  
CAMarten

ECU number for '83 l28et

Recommended Posts

History: bought a hacked up l28et swap in a '78 280z and I'm trying to figure out what is what. It took me forever simply to find what front brake pads were on there! (from a toyota 4x4)

 

I was able to find that out, and most of what I need, from researching posts on here, but there is one thing I'm having a really hard time finding, and that's the proper ECU for my engine. The one that was in there is #A11-600 000, and I'm relatively confident that that is indeed from the original '78 N/A engine, and wont work with the existing '83 turbo engine. right now it's running SUPER rich and everything else has been tested/replaced. I found a few used ones that claim they are from an '83 turbo #A11 654 806, but some forums say that those #'s only are from the N/A model. help please! 

 

 

I've been doing a ton of research and every time I find what I'm looking for it conflicts with what I've found already, before I buy anything I'd like to know for sure it's the right one.

 

Thanks,

 

Caleb 

Edited by CAMarten

Share this post


Link to post
Share on other sites

Here are a couple of sources.  But if you're running the 1978 NA ECU, you must be running an NA distributor also, not the CAS that the ECU needs.  The 1978 ECU doesn't do ignition control.  You need the whole ECCS (S for System), or aftermarket engine management like Megasquirt.

 

http://jimwolftechnology.com/wolfpdf/ecu-id.pdf

 

http://www.jatan.net/tsbs/040359.pdf

Share this post


Link to post
Share on other sites

That is correct, originally I was using an MSD ignition box, and ended up switching back to the stock ignition and engine control thinking it was original to the '83, but it turns out is original to the '78. I still have the '83 distributor, ignition and AFM that I plan on putting back in when I change out the ECU, and I'm thinking most likely I will have to replace the whole harness as well, as I'm not sure what engine that is originally from either... this car is all over the place.

 

Those links are very helpful thanks! but once again it conflicts with everything I have found so far... according to that the proper ECU # is: A18-604 046... I think you're right, I may just go completely aftermarket since I'll most likely have to replace everything anyways :(

 

This has been a very humbling project for sure, with how much research time and effort I've put into just finding out what is what I could have built the engine from scratch 2 times by now! I want to track down whoever did this swap originally and give him a piece of my mind...  

Share this post


Link to post
Share on other sites

I don't see 604 046 anywhere on the official Nissan factory Technical Service Bulletin.  That's the one I'd use.  The jimwolf page might be misleading.

 

Edit - actually I did find it. The other ones might work too though.  Are you running an automatic?

post-8864-0-55817600-1445816713_thumb.png

Edited by NewZed

Share this post


Link to post
Share on other sites

It's extremely easy to tell if you have an ECCS ECU (Turbo) or an EFI ECU (N/A).  Just look at the ECU connector.  The L28ET ECCS ECU has three black plugs that the harness connects to.  The L28E EFI ECU has ONE long plug.

 

You can use any '82 or '83 ECCS ECU with that engine ("automatic" or "manual" doesn't really matter).  BUT, if you're using the stock ECU, you'll need a stock ECCS harness.  SO...  If you need both an ECU and a harness, you can use any ECCS harness and it's matching ECU.  What I mean by that: You can use an '81 ECCS ECU and harness (the harness will have (and need) dropping resistors) on any L28ET.  You can also use an '82 or '83 ECCS harness and ECU (no dropping resistors on the harness).  The '82 and '83 are interchangeable.

 

The only other early ECU that uses 3 black plugs is a Z31 ECU (early 300ZX).  A few folks use a Z31 ECU to run their L28ET's BUT it needs to be rewired slightly to make it work properly.  Well documented in archival threads.  Would have been helpful if you'd posted pictures of what you have...

Share this post


Link to post
Share on other sites

Thank you very much cgsheen! Looks like I'll be needing a new harness and ECCS ESU as well. I'm probably going to stick with stock since I'd rather not fiddle with rewiring things at this time. I just want to get my baby RUNNING! it's been so long and I NEED this! Just rebuilt pretty much everything else and I can't tell you how sad I was when it still didn't work after replacing/rebuilding pretty much everything else. Every time I pull one thing to fix I think: 'well since i'm already in there I might as well do this too...' famous last words.

 

Thanks again! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...