Jump to content


Photo
- - - - -

280zx turbo ignition control module swap


  • Please log in to reply
24 replies to this topic

#1 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 19 August 2016 - 03:07 PM

I currently have a L28ET from a 280zx turbo in my 78 280z. The car has been intermittently dying on me from time to time and starts up after letting it cool for 20 minutes or so. All of the research Ive been doing points to the ignition coil transistor which in my case is located on the coil bracket. From what I understand the 280z has the ignition control transistor located near the fuse panel passenger side in the car. Mine is there.  Is there a way I can run wires from my coil to the engine compartment to the module located in the car and use that module instead?  Thanks.


Edited by rickyellow zee, 21 August 2016 - 11:07 AM.


#2 Chickenman

Chickenman

    Can Charge Rent

  • Members
  • PipPipPipPipPip
  • 502 posts
  • LocationCanada

Posted 19 August 2016 - 04:12 PM

Personally, I'd stay with the Matchbox Module ( E12-80 ) . Much newer technology and they put out a much more powerful spark than the Transistor boxes on the 280Z. The 1975 and 1976 boxes are the worst. Not much more spark energy than stock points system.

 

On " the 510realm" we have Turbo cars pushing 18 lbs of boost on the Nissan E12-80 module with no spark blow-out. Nothing wrong with that!!

 

If memory serves me correct current draw on the 75 and 76 boxes is only 2 amps. That pretty wimpy. I'll try and find the specs on the E12-80.. 4 amps seems to be ringing a bell.


Edited by Chickenman, 19 August 2016 - 04:16 PM.


#3 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 19 August 2016 - 04:42 PM

My car is a 78. Not sure the rating for that module is. Maybe different than the 75 76 box.

 

I tried the HEI swap and it would not rev past 2000. I wired it correctly Im sure of that. I went back to the stock L28ET ignition module transistor and its intermittent cutting out. It cuts out maybe once a month or so.


Edited by rickyellow zee, 21 August 2016 - 11:07 AM.


#4 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 19 August 2016 - 07:12 PM

Here's an option.  A more modern transistor in a nicer package.  Same function.  http://www.xenonzcar.com/z31/prw2.html

 

Many people use the HEI module in the place of the ignitor.  It has a better writeup, easier to get installed.



#5 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 19 August 2016 - 08:18 PM

The link you posted is for the Z31.The L28ET module is 4 wire and the modern PRW-2 has 3 wires. I'm gonna have to look into this. Looks promising.


Edited by rickyellow zee, 21 August 2016 - 05:44 AM.


#6 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 20 August 2016 - 04:24 PM

I couldn't find a write up on this mod. I searched the net but no luck. I only found a write up on the z31 'ecu upgrade. Does this module work with the l28et? Thanks.

#7 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 21 August 2016 - 10:45 AM

Rix diagram

I was thinking of trying this out and seeing if it works. This is using the 1978 280z ignition Module and the L28ET wiring and ECU(the car is a 78 280z with the L28ET swap from an 83). I am using the yellow signal wire to feed the 280z ignition Module instead of the red and green wires from the distributor that was used with the original set up. What do you think?



#8 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 21 August 2016 - 10:59 AM

It might.  Seems like Red should be grounded though.  But Chickenman was right, the 77 is a low current system.  It still uses the ballast.  Considering that and the fact that it's 38 years old, the odds of rapid module failure are high.

 

Why not use the HEI module?  It seems to work.  http://www.zdriver.c...hevy-hei-27569/

 

Or use the same logic you just showed, identifying the trigger wire, on the PRW-2 module.  Just figure it out.  The Pahfinder wiring diagrams are on the nicoclub web site.



#9 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 21 August 2016 - 11:03 AM

Mine is a 78. I mention earlier it was a 77. I was wrong.


Edited by rickyellow zee, 21 August 2016 - 11:07 AM.


#10 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 21 August 2016 - 11:06 AM

I tried the HEI. I wired it up as per "skittles" diagram on another site. It would not rev past 2000. Checked the wires, checked them again. Posted my results on another forum and everyone said my wiring was correct but it didnt work correctly.



#11 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 21 August 2016 - 11:17 AM

The 78 module might work.  Or it might have the same problem as the HEI.  Actually, considering the original design intent of the HEI it's kind of surprising that it works as an ignitor.

 

The PRW-2 is designed to work like the ignitor does.  But you might get lucky with the 78 module, and it is a "high-energy" system, using no ballast and .040" spark plug gap.  Good luck.



#12 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 21 August 2016 - 11:30 AM

Will do! So you think its a good idea to ground the red wire eh? I will try and see what happens. Thanks.



#13 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 21 August 2016 - 03:31 PM

Here's a scheme that should work to use the PRW-2 in place of the ignitor.  Copied from the 1995 PF FSM, page EF&EC-8, and Rockauto.com.  The PRW-2 is about $60-100 on Rockauto, but only $25 plus at PicknPull.  About the cost of an HEI module.

 

No guarantees, I just followed the lines of the wiring diagram.

 

L = coil negative

W/B = ECU trigger

B = ground

Attached Files



#14 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 21 August 2016 - 03:44 PM

Here's the 1983 scheme, for comparison.

Attached Files



#15 cgsheen

cgsheen

    Junior Member

  • Members
  • PipPipPipPipPip
  • 537 posts
  • LocationArizona

Posted 21 August 2016 - 08:08 PM

The Coil/Ignitor from a VG30 engine can also be used as a replacement for the stock coil/ignitor - it's a package, newer style, and easy to wire.  It's been my experience that the Ignitor is easy to blame and not normally at fault.  Not saying that it can't happen, but mostly I find the problem elsewhere.  HEI worked flawlessly on my L28ET for the time I used it.  If a new ignitor doesn't fix the problem, look at the CAS optical module (mine had a solder joint that cracked on the 4-pin connector and caused a very random shut down), and look at the rest of your wiring and connectors on the ECCS harness - they gotta be clean and tight.


1974 "Early" 260Z: '83 L28ET - F31 ECU MAF Coil TPS - T04E - FMIC - 400cc Injectors - MTX-L wideband - NIStune enabled! - '83 5 speed - coilovers - Big Brakes up front - Sakura Garage, Tempe, AZ


#16 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 22 August 2016 - 08:35 AM

I checked and rechecked every wire in the engine bay and at the ECU. When I got the car the wiring was a mess but I cleaned it up. New injector plugs, etc....I modified all the eccs plugs at nice n tight.

 

I'm gonna work on the car tonight and try and wire the stock 78 module. If that works great but if not I'm gonna look into the PRW-2. Also gonna look into the CAS. Make sure everything is on point. Thanks



#17 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 22 August 2016 - 08:46 AM

I'm surprised the PRW-2 doesn't require a 12V wire like the HEI and the stock unit does. Hmm.



#18 cgsheen

cgsheen

    Junior Member

  • Members
  • PipPipPipPipPip
  • 537 posts
  • LocationArizona

Posted 24 August 2016 - 11:22 AM

The coil/ignitor wiring is different in the early-to-mid 1990's Nissan's that used the PRW-2.   (true but not relevant)

 

From the Power Transistor wiring diagram above:

W/B = transistor "base" = trigger = input from ECU (Y/W on Ignitor "T" connector)

L = transistor "collector" = voltage input or source = (on L28ET Ignitor this would be the B/W +12V (battery voltage) @ IGN ON)   GND - The stock ignitor gets it's GND from the frame (coil bracket attached to fender...) 

B = transistor "emitter" = signal out to coil = (same as L (blue) on L28ET ignitor -> "-" terminal on stock coil)

 

The difference (and confusion) in the wiring:  Power @ IGN ON in the later cars is delivered to the coil and then thru the coil to the Power Transistor collector.  (On the stock L28ET, it's the opposite - power @IGN ON goes first to the Ignitor, then from the Ignitor to the coil "+" terminal)  The output of the emitter is shown to go to the coil to trigger spark, but is also "tee'd" to a pin on the ECU that is tied to GND in the diagram.  I'm not smart enough to know why the tie to ground...  (again, not relevant...)


Edited by cgsheen, 30 August 2016 - 09:58 AM.

1974 "Early" 260Z: '83 L28ET - F31 ECU MAF Coil TPS - T04E - FMIC - 400cc Injectors - MTX-L wideband - NIStune enabled! - '83 5 speed - coilovers - Big Brakes up front - Sakura Garage, Tempe, AZ


#19 rickyellow zee

rickyellow zee

    Always Here

  • Members
  • PipPipPipPip
  • 232 posts
  • Locationtoronto

Posted 28 August 2016 - 03:02 PM

123
Like this?


#20 NewZed

NewZed

    Clandestine Moderator

  • Members
  • PipPipPipPipPipPipPipPip
  • 5213 posts
  • LocationWashington County, Oregon

Posted 28 August 2016 - 03:24 PM

(On the stock L28ET, it's the opposite - power @IGN ON goes first to the Ignitor, then from the Ignitor to the coil "+" terminal)  The output of the emitter is shown to go to the coil to trigger spark, but is also "tee'd" to a pin on the ECU that is tied to GND in the diagram.  I'm not smart enough to know why the tie to ground... 

I don't know that the swap will work as I showed, but the ignitor is after the coil negative, with no positive feed, according to the 1983 wiring diagram.  So, not sure if you're mis-remembering the above.  I just compared diagrams, the 1983 diag. is Post #14 above.

 

The HEI is a "smart" module, which does current-limiting, aka dwell control.  Maybe the 12V feed is involved there.  Or the zero-crossing trigger circuitry, for use a VR sensor.  It has much more functionality than is used when it's wired up as a power "switch".  Overkill and just lucky, really, that it works.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users