Jump to content

Turbo swap jumping tach and missing

Recommended Posts

At about wits end with this motor. So it misses when the tach jumps around, it seems to be an intermittent problem. It however seems to be getting worse. Heres a Video:




Ignitor is good tried two of them same result

New Dizzy with CAS

Checked CHTS

Brand new cap, rotor, plugs, and wires

Tried two coils both gave same results


Im trying to see if anyone else has had this problem before. I couldnt find any info on this.

This is my second ecu, This could potentialy be the problem, however I will look more into it when I get home from work.



Link to comment
Share on other sites

  • 2 weeks later...

Gently wiggle the wires near the ecu connector when this happens and see if that has an effect.......be gentle....it only takes the slightest pressure do this test and excessive pressure can be tough on the connection where the connector is soldered to the ecu board.


Also.....try using jumper cables between the engine and the body to test if it gets rid of the problem.

Link to comment
Share on other sites

You know I've tried almost everything at this point I have 2 ecus, 3 ignitor, I'm on my third dizzy cause the last one was rebuilt wrong, I've played with the injectors and there not coming from there, I've tried two afms, 2 CHTS, and I've even tried ,different plug wires, and different coils. Out of all the stuff I have I get the same result. I've gone through my entire wiring harness and fusable links to see if there was a grounding problem. I could not find one. Nothing was out of place. It appears to be a spark issue.


It tends to only show up once the motor is warm. I get no weird voltage reading from the ignitor or ecu to ignitor.


I'm pretty well stumped.

Link to comment
Share on other sites

I thought vacuum leak a couple weeks ago as well, My boost/Vacuum gauge does not read any abnormalities. I also cannot find any leaks or problem areas. I guess the next thing to do would be to actually do a test on it.


Im 99% sure its a spark problem, as I went out to start the car and it would not start. No tach signal, and no spark. Did a number of various tests (voltage to ecu, voltage to ignitor, power to coil, and several more)couldnt find the problem. After two days of trying to get it to start, day three comes along and car starts up like like nothing is wrong. Then the problem came back after a few minutes.


I think I may just put my NA motor back in it, as I can still drive the car then.

Link to comment
Share on other sites

That really sounds like a distributor issue.


Next time it refuses to start, leave the key on and wiggle the harness where it plugs into the bottom of the distributor.


If you hear the injectors click, then you have an intermittence issue within the potted electronics of the distributor.

Link to comment
Share on other sites

I have checked the wiring a number of times now, I have also verified my wiring with a friend of mine who has a 77 swapped L28ET. I talked to the people at baxters aka "bastards" and they think it could potentially be a bad cas within the new dizzy as well. He gave me a number to call to talk to a local distributor guy. Shortly after called him told him my story and he said the guy I needed to talk to was not in today and gave him my number. Told me he would have him call me the next day. On day three now.


I think im going to try and find a know good distributor and if I still continue to have problems Im going to get rid of this motor. Way to many gremlins.


Just to refresh everyone this is already my second remaned distributor.

Edited by abc_was_here
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...