Jump to content
HybridZ
98cobra+75280z

Oil pump only pushing 25 psi

Recommended Posts

I recently rebuilt my '82 l28et for my '77 and am having oil pump issues now.  The car idles fine but with cold oil my mechanical only sees around 20 psi and as it warms it goes down to 12-15 like it use to.  My worry worry is that with cold oil the car use to see 45-50 psi at idle and increase with revs to 60 or so.  With revs the pressure never goes above 20 psi.  I installed the pump and shaft like the "how to rebuild your datsun OHC" book states but ran into a problem with the oil squirt hole not lining up with the punch mark on the pump shaft gear.  With the marks lined up the dizzy shaft end isn't even close to being lined up.  When I line the tang of the dizzy side up to where it needs to be the marks on the shaft and pump housing no longer line up.  The pump is off an '83 turbo motor where as the shaft is from the '82 motor.  I don't see how the shaft mark needs to be lined up with the pump housing since the shaft just spins along with the motor but maybe I'm wrong in this thinking.  I am planning on getting a different gauge to see if maybe my gauge is faulty.  Taking the oil cap off I do see oil squirting up to the cam but I am not sure if it is a sufficient amount.  Any ideas on what may be causing my lack of oil pressure.  Oh and the oil pick up tube is free and clear from debris as well.

 

Thanks guys,

 

Kevin

Share this post


Link to post
Share on other sites

If the dots don't line up, that spindle shaft is either twisted or the gear has spun. I can't imagine there would be sufficient clearance even with good oiling for the shaft to spin easily on the gear, but a little slip could certainly cause the problem you're having.

Share this post


Link to post
Share on other sites

The gears will spin. It affects timing, not pump output pressure...save for the millisecond the pump slows while the spindle slows in relation to the gear rotational speed.

 

Seen the gear jump anywhere from 7 to 180 degrees on a dyno pull from force reversals on hard drop throttle under full power.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...