Jump to content
HybridZ

Norman V

Members
  • Content count

    15
  • Donations

    0.00 USD 
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

0 Neutral

About Norman V

  • Rank
    Newbie

Profile Information

  • Location
    Miami, Florida
  1. Norman V

    WTB: LSX 240 or 280

    Message me
  2. I have a 240z in Miami if you need another. =)
  3. Norman V

    MY NEW BABY

    Congrats
  4. Norman V

    SOLD Rota RB-R 17x9.0-13 / 17x9.5-19 BNIB

    I'm very interested. Could you get me a shipping price to Miami Florida? Zip = 33162 Delivered to a commercial address may be less expensive. Thanks in advance.
  5. I'm Interested in these. Let me know when available.
  6. Norman V

    Post pics of your z's here!!

    This is beautiful. What are your wheel/tire and suspension specs?
  7. I have a 1971 240Z and I want to switch up my wheels to the 17" Rotas and flares. I currently have stock springs that are beat to hell and KYB's. If I run lowering springs with the 17's and flares will It look proper or do I need to run coilovers? I'd like to run a 275 rear tire. I don't plan to track this car but I'd like a stiffer and lower ride height but not slammed. I would like to have the wheels and tires fill the gaps nicely. Can the 17x9, 17x9.5 combo with a 275 rear and flares work with just lowering springs and look right? Thanks in advance and here is a pic of my car minus all the chrome blacked out that I just did.
  8. I'd Love to know what side skirts those are. Looks awesome.
  9. Have you checked the coil and module? They tend to go bad.
  10. Norman V

    Will not go into gear.

    Thanks guys. I will check the slave first. I know I replace both the master and slave about 9k miles ago. I'm hoping its not the clutch.
  11. Hey guys. Today I was driving my 240Z and I felt the shifter getting harder to put in first. As I was heading back home I would have to pump the clutch pedal twice to get into first at stop lights. When I got of my exit I stopped at a light and then I couldn't get her to go into any gear no matter how much I pumped the clutch. Finally I pushed the car to the side of the road and called a tow truck. What may be the cause to this. The car has been shifting perfectly all this time and I'm not sure if its the clutch or the master or the slave. With the engine off it will go into all the gears but while running won't go into any. All help will be appreciated. Thanks in advance.
×