Jump to content
HybridZ

Triple Blowthrough Turbo


Dat73z

Recommended Posts

  • Replies 176
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Thanks @AydinZ71 I think I actually have something similar left over from when I set up my tig machine. I seem to recall it was RV cable or something. 

 

Tonight I made some battery cables and hooked up the major circuits in the car. So far so good and no smoke so the gremlins get to stay in my car 😁.

 

Originally the cables were supposed to be temporary but I may just run them. I took an old set of cables I had and cut the tired ends off on a bandsaw. Then I hydraulic crimped some autozone special lugs on the ends and protected them with marine style heat shrink. 

 

It's been a few months since I started this but I've already cleaned up the harness and replaced all the connectors and crimp connections. Next steps are to test each circuit and ensure I'm happy with the layout in the car. Then pull it all out to loom. 

20220617_193948.jpg

20220617_194559.jpg

20220617_194749.jpg

Link to comment
Share on other sites

This morning I got most of the harness routing complete and tested. Wiring is probably one of the easiest but least enjoyable build aspects for me, next to sanding and bodywork. 

 

I rerouted the harness through some grommets on the valence support as the cooler packaging now takes up the original harness area. 

 

I think the strategy will be to zip tie every few inches to hold the shape of the harness/bends. Then when I pull it back out to loom, snip the zip ties as I get to them with the harness tape

20220618_071609.jpg

Link to comment
Share on other sites

This evening I was able to work on the harness a bit more. 

 

I'm down to the last 3 circuits which need to be addressed before I start tidying things up: 

 

1. Fan Controller - forgot a ground whoops

2. Ignition system - it seems the green/white wire which I thought had 12v ign has nothing so I'll splice into the black/white upstream

3. Headlights - no idea yet, I can hear my headlight relays clicking but I'm only getting like 0.03v

 

Starter and everything else including the radio and power antenna work. Really brings me back to when I used to drive this car every day. Hopefully again soon

20220618_175043.jpg

Link to comment
Share on other sites

Had 15 mins after dinner and sorted the ignition system. 

 

I managed to pull the curves down that the engine ran on during the dyno. I think at 9-10psi it was at 350hp and trq. The curves are fairly typical for this type of setup including the map advance off load, the only difference really is the map section for boost retard. 

 

I also came to the realization that technically I could put some fuel in, fire the car up, and go for a drive right now. After all of that though I'm going to stay the course and finish this off right. Tomorrow I'm going to keep working the harness and prepare it for looming. 

 

I should also probably get the paperwork in for the tags and insurance. I haven't checked 240z prices lately but I'm going to assume I should increase my coverage anyways after all of this. 

 

 

20220618_204723.jpg

20220618_204744.jpg

Link to comment
Share on other sites

This morning I got up early and kept working the harness before heading out for Father's day. 

 

I forgot that I had made some custom horn brackets for PIAA horns as the turbo cooler packaging now takes up the space for the OE horns. 

 

The brackets I originally prototyped out of AL. The final version I made is 1/16 SS plate for rigidity. The brackets postion the horns to clear the intercooler and valence with a gap, and also helps to locate/support the harness behind so a multipurpose bracket

20220619_064501.jpg

20220619_080012.jpg

20220619_081804.jpg

Link to comment
Share on other sites

Tonight I had a few minutes to keep working the harness and got it mostly routed around the coolers. 

 

I think it's been almost a decade since I've owned this Z. When I purchased the car the PO was feeling under the fenders and told me there was a spare key hidden somewhere but he couldn't find it. Lost over 30+ years but I guess I finally found it

20220619_204440.jpg

20220619_204505.jpg

Link to comment
Share on other sites

Out of time tonight but I managed to get the harness organized up to the breakouts for battery accessories. 

 

Originally I was going to integrate all harnesses into one but I've decided to keep the fan and headlight harnesses separate for serviceability. 

 

I was also pleased to find my routing and mounting choices for the oil cooler lines and intercooler piping made working in the area a breeze. 

 

Really hoping I can get through this in a couple more evenings because leaning over the fender and crawling around is killing my back

20220620_184642.jpg

20220620_190546.jpg

Link to comment
Share on other sites

This morning I continued with organizing the harness accessories. Eventually I want to fabricate some power/ground busses and a relay panel behind the dash, but I didn't want to get into all of that for this phase of the build. 

 

I think I need to get some round head allen hardware for the terminals as the bolt heads press against the terminal covers. A minor nickel and dime annoyance

20220621_064941.jpg

Link to comment
Share on other sites

Over lunch I was able to tidy the wiring to the firewall. 

 

I also forgot my friend who shell swapped a couple years ago gave me a blade type fusebox as he couldn't use it in his S1 shell. 

 

Unfortunately his old car has some wiring issues and there was one connector melted to the plug. Through the magic of crimping and soldering I was able to restore the fusebox. All circuits work and now I can use blade style fuses. 

20220621_090618.jpg

20220621_113355.jpg

20220621_113935.jpg

20220621_114324.jpg

20220621_124600.jpg

Link to comment
Share on other sites

Looking good! Are you trying to keep the connectors OEM? I hate those connectors, but then again I dislike connectors in general 😅😂

 

also, consider wrapping all your wires sitting on your frame rail in the engine compartment into a large diameter loom. It will help keep the oil and grease from getting all in there. Amazon sells them for pennies 

Link to comment
Share on other sites

Thanks @AydinZ71 The OE style connectors are because I already have a big box of them. 

 

The strategy I'm working is to get the harness routing and shape exactly how I want it with the zip ties. I will then pull the harness back out of the car and loom with this Tesa tape, snipping off the zip ties as I get to them. I think I have like a dozen rolls of this stuff

20220621_092012.jpg

Link to comment
Share on other sites

Thanks, that means a lot. Slow and methodical is how I approach things I dislike such as wiring and bodywork so hopefully I won't need to redo this again anytime soon. 

 

After some further thought I think I'm going to completely eliminate the late 73 fuel pump add on harness and relays. Wire in a dedicated oil pressure switch instead and remove all that factory complexity. Unless there is a compelling reason to keep it that I'm missing. 

 

Now to order an oil pressure switch and wait for parts again. 

Link to comment
Share on other sites

This morning I added the breakout for the oil pressure fuel pump cut switch. 

 

I saw online O'Reillys can get the 3 terminal sensor within a day or two so I'll call and order that today. I also need to get a different color wire for the pump relay trigger so I don't confuse myself in the future. There is currently 12v starter solenoid (under heat shrink to indicate) and 12v switched ignition hooked up. 

20220622_064537.jpg

Link to comment
Share on other sites

Posted (edited)

My oil pressure switch came in the evening so I wired it up.

 

I realized there is one three prong relay in the cabin dangling which I can't remember where it bolts up. There's a phillips screw on the floor so it must go somewhere on the pass kick panel.

 

Once I figure out where that goes and finalize the wire lengths there then I can pull the harness back out. 

 

Edit: it is the horn relay and it gets tucked way back in there

20220623_184504.jpg

20220623_184525.jpg

Edited by Dat73z
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...