Jump to content
HybridZ

Triple Blowthrough Turbo


Dat73z

Recommended Posts

Hopefully it's something simple, chasing down rattles and vibrations is pretty annoying. If you were closer I'd say swing by and grab my Mishimoto fan shroud for the twin spal 12s! 

 

Couple of minor weekend updates since I'm still waiting on parts. 

 

I final mounted the hot side piping with the murray clamps. They are surprisingly simple for their cost. Basically a worm clamp with a constant tension mechanism and an inner band to prevent cutting the couplers/distribute forces more evenly. 

 

I pulled my gas tank about a month ago because I wanted to double check a few things and I'm glad I did. I was concerned with delamination of the tank lining, in-tank fuel movement, and the return hose submerged in fuel/degrading since it wasn't rated to be submerged. 

 

The redkote tank liner easily peeled off the AL tank cap but seems very well adhered to the rest of the tank so I'm going to run with it. I added 2 one way check valves in the baffle plate as the gap below was coated over. I also replaced the in-tank 1/2" return hose with a SS hardline. 

20220709_182230.jpg

20220709_180404.jpg

Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 339
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Had to take a break for a while due to a close friend's wedding but final parts came in so I started assembling. 

 

The car now runs and drives but I won't be able to shake it down and start tuning until this weekend. Somehow during the pandemic the DMV didn't process my non-op reg but they gladly took my fees and didn't send me a notice to let me know. Or maybe they did but I also moved like 3x this past couple of yrs. So now I need to go to the DMV to dispute a few years worth of backfees on Thurs. 

 

On the bright side, the 3.2 stroker turbo sounds and feels like a monster. 

Link to comment
Share on other sites

Been working 12 hour shifts back to back and needed to unplug so I started in on the tuning tonight after work. 

 

I temporarily capped off the vacuum ports and got the carbs mixtures generally set and balanced. 

 

I'm still getting some lean popping out of all barrels with my afr gauge reading 12-13. My mechanical fuel pressure gauge is also showing 4psi while the electronic is showing 1psi. I think I need to go through and check all grounds just to be sure, but I'm not trusting my gauges too much right now. 

 

Tomorrow I'm going to try and dial in some more fuel after I get the registration sorted, then begin road tuning and continue shaking it all down. 

Link to comment
Share on other sites

Today I managed to get the car re-registered and promptly went for a nice long drive...in circles to the gas station Lol

 

I got everything set up just enough for the car to idle and drive decently but I can feel the jetting is slightly off. Also as the car has been heatcycling and new parts wearing in, the settings are moving around but it's getting smoother and smoother as the fuel circuits are getting flushed. 

 

At the advice of my buddy who rebuilds and tunes sidedraft carbs I'm going to focus on driving the hell out of this thing NA for the next couple of weeks to let everything wear in and get the jetting on point.

 

Once I'm satisfied with the baseline I'll put the surge tank on there and start boosting...to the dyno at my friend's shop for more tuning 🤣

 

In the meantime as with all ground up builds there are a few non-turbo related items that have crept up during shakedown runs to address. 

20220721_174403.jpg

Link to comment
Share on other sites

This morning I had a couple hrs to keep shaking the car down so I've been racking up the miles and breaking things in. 

 

The jetting on the car is close but still far out. Unfortunately the 60 pilot jet was drilled and soldered up so I don't have any idea what I actually have. Fortunately my buddy has some 62.5 and 65 fixed air pilots which should be a good baseline for a 3.2 stroker. Hopefully I can test those out this weekend. 

 

As I've continued shaking the car down I've noticed I have some significant oil overcooling as expected. Even after idling for an hour and driving around for another, the oil temps never exceed 180. I think I'm going to obscure the oil cooler with cardboard for now and keep tuning. 

20220722_104314.jpg

Link to comment
Share on other sites

Thanks @rossman

 

100 miles down maybe 400 to go before I get to a good state of tune. 

 

I'll def post some pics and vids. As I've been doing research on these setups over the years and actually doing it now I've found a lot of forum posts and very few vids of how these setups run on a hot L.

 

We know from 80s japan they're capable of really big #s and low 1/4 mi times. However, most vids I've found online are of poorly running/tuned setups where rapping the throttles results in major bog or popping.

 

So I'm going to really focus on the tune for this build and get it dialed in to respond like a super responsive NA before boosting and tune more from there

Link to comment
Share on other sites

Today some friends came over and we were checking out the car when the lower rad hose blew. Not sure what's going on but I've been struggling through some cooling system pressure and boiling issues. 

 

I bled the car for over 1 hour 2 times elevated with a spillproof funnel and kept getting more air out. Before the lower coolant hose blew I was seeing maybe 190 at the tstat housing and 180 oil temps with a 16lb rad cap. Nothing is burning or mixing so far as I can tell. 

 

I bead rolled the ends of the coupler I made a bit more (it blew out on the side which was "factory" rolled) and hopefully I can shake it down more tonight, and it was just a tightening issue. I mentioned earlier in the build I wasn't too confident in the factory hose clamps for a high performance app but I've been working with what I have. 

 

It was a bit of a bummer that I basically dumped 50$ of coolant on the ground but fortunate it happened right in front of my house so I was able to wash it out and animals didn't get to it. Another positive note is my buddy lent me some OER jets when he stopped by and another friend has a bunch they can lend me. 

 

Just another day of shakedown I guess but it was good to see friends that I haven't seen for years

20220724_182742.jpg

IMG_20220724_161418_896.jpg

Link to comment
Share on other sites

So after rebuilding the cooling system I put in the jets my buddy lent me. I suspect Rebello tuned the engine for straight dyno power pulls 4k+ rpms as the drilled/soldered jets in there responded crazy going into insane rich levels on tip in with 0 pump volume and still lean popping at idle an 10 afrs so a definite fuel metering issue. 

 

With the new virgin jets, the engine is responding now like any other sidedraft setup I've tuned which is going slightly lean on tip in with 0 pump volume and much more responsive. 

 

 

 

Unfortunately it was getting late and most of my neighbors have young kids so I shut it all down before 9pm. But at least now I can start re-baselining and actually tuning for a super responsive NA later this week. Hopefully I won't be pulling straight 12-14+ hr days at work again but we'll see tom evening. 

Link to comment
Share on other sites

Btw huge shoutout to my buddy Josel @ sidedraft specialties. And Craig @ Simtec Motorsports. So many people to thank over the years let alone a very understanding spouse lol. I definitely couldn't be where I am today on this build without the Z community. 

 

It's kind of crazy I've known a lot of these people and met so many more along the way over the past decades but I'm glad even with the way things are in the world now we can still get together and share the same passions and keep helping each other build our dreams👍

Link to comment
Share on other sites

Yesterday evening I managed to get the cooling system back together and bled out. 

 

I'm still getting nucleate boiling/after boil at the back of the head and around the heater core/branch feeding the turbo. 

 

Not sure what's going on but at the suggestion of some seasoned and super helpful Z people on the FB groups I'm going to run down the list this next few days to really drill down and diagnose: 

 

1. Remove tstat and check for strong flow at the top of the rad across the fins (preliminar test for flow, even new water pumps can be bad)

2. Test and replace tstat (they can be bad brand new, have a new 160 in there now)

3. Check for flow through radiator, ensure not blocked (new builds can have sediment etc. flow out and block even a new rad) 

4. Check water pump (not sure what's in there as Rebello had installed it) 

 

On one hand I'm glad I'm catching this now before boosting and blowing up. On the other hand, the teething issues are fairly annoying. I just want to go out and drive! 

 

 

Link to comment
Share on other sites

So after some further review/discussions and help from the community, it seems the turbo coolant line routing I have won't work. What I thought were air pockets boiling out at the heater core branch area is likely flow reversing from the hot turbo causing localized boiling in that area after shutdown aka nucleate boiling/after boil. 

 

For the heater core branch I'll block off the current feed there with a standard -6 cap. 

 

Now I'm trying to decide whether to feed the turbo from the lower coolant neck by the water pump, or the drain at the side of the block.

 

I think either would work but the lower coolant neck would have lower temps/larger delta T but require me to wrap a hose all the way around the block.

 

The block drain location may have slightly higher temps/pressure but would allow a more continuous gradual rise in the line run for thermal siphoning. It would also be a shorter hose run and hidden by the turbo. 

Link to comment
Share on other sites

@calZ it is currently like this: heater core branch on suction side > turbo > lower tstat housing. 

 

After some deliberation I ordered a 1/2 BSPT to 37 JIC fitting to go: Block drain > turbo > lower tstat housing.

 

Mainly because I didn't like the idea of wrapping a hose all the way around the block. 

 

 

Current.png

Link to comment
Share on other sites

That is similar to how mine is routed. Bottom of thermostat housing > turbo inlet > turbo outlet > water pump inlet. I've never had any issues with it overheating. The arrows on either side of the turbo in that diagram are drawn backwards. Coolant flows into the turbo from the thermostat housing and out of the turbo to the heater hose then water pump inlet.

Link to comment
Share on other sites

@rossman are you returning to the lower rad hose inlet direct at that location? Or as I currently have it routed by the heater core branch? In the vid above you can see the AN fitting I welded onto the heater core branch and that is the return area. 

 

I was conferring with Dave/Brian Rebello and Richard Boyk on this routing specifically, and some concerns were raised there with low pressure or backflow in that area after shutdown (e.g. pump pressure gone) which seems to jive with the boiling I've been getting there. I wish I had an IR thermometer but those turbo coolant lines get HOT. 

 

I think the consensus is right at the lower rad inlet shouldn't have issues but I'm still considering the block drain as it's just in a more convenient location + will have a constant and gradual slope up instead of wrapping the hose all the way around the block with all of those elevation changes, etc. In conferring with Tony D it seems the block drain would work too but would be warmer (e.g. setup for thermal siphon trickier) and have higher pressure (e.g. flow more through the turbo when running). 

 

Hopefully I got that all right. I'm a bit out of my league when it comes to coolant flow/temp characteristics in the L. Just trying to get something that works 😁

Link to comment
Share on other sites

Isn't that how it's routed stock? There aren't two hoses going back to the water pump inlet. It's been a while since I stripped my engine, but I thought the heater just steals coolant from the turbo return? 

 

Tony is always big on that method because once the engine stops, the turbo can thermally siphon the cold water that just came out of the radiator and push it towards the tstat housing. 

Edited by calZ
Link to comment
Share on other sites

Posted (edited)

@calZ I'm not sure how the stock was routed to be honest. I've seen a lot of factory and aftermarket cars routed from pump outlet to Tstat housing and block to Tstat housing.

 

I think most of the cooling for the turbo is done by the oil, and in my car it hasn't gone over 180F yet...but with the way my setup is currently, my heater core line off the branch with the turbo return is boiling coolant on shutdown.

 

Either way, I do want to try and set things up to thermally siphon so I'll need to be careful with the routing of the lines to ensure smooth flow up and towards the rad after shutdown. 

 

@rossmanGood point about running under the block, I had not considered that. I have a few days to mull things over while waiting for parts but that sounds like a fairly clean approach. 

Edited by Dat73z
Link to comment
Share on other sites

In my experience, adding coolant to the turbo bearing cartridge is most valuable in preventing the oil from cooking (and fouling the bearing) between boosting. If you have appropriate oil pressure at your turbo, you should have sufficient flow to keep the bearing cool during operation. The coolant is a heat-sink to prevent the bearing and oil temperature from peaking above when the oil begins depositing coke dramatically (300deg+?). Most valuable for short runs where the car drops back to idle with a glowing-hot turbine housing, simultaneously oil pressure dropping (idle). I have seen folks with typical oil-bearings without a turbo-timer having no problem thanks to the water jacket. In general, I just let the car idle for 5 minutes before shutting down. 

 

In this way, the thermal-syphon works pretty darn well. Even is worst-case, temperature of the water rises above 250 it will start to vaporize which makes room for water column to take its place. If done correctly, it should be self-correcting (some call it fail-safe). At least for street applications, I have not seen a need to ensure active flow through the bearing housing. 

 

Always exceptions. These are just general observations.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...