Jump to content
HybridZ
Rumnhammer

Chris Rummel's easy follow RB into Z wireing guide

Recommended Posts

I've been watching this thread for a while and have appreciated the shared wisdom of its users. Current putting a rb25det into a 260z. Lots of fun and expense. So my first question here is what is the this thing I have pictured and where does it go. It came with the loom. I've got most of it figured with the help from the forum but I'm much better with bits of wood and glue than cars.

 

post-181-003581000 1345510441_thumb.jpg

 

** EDIT: I re sized it for you.

 

 

Please Resize Images

http://forums.hybrid...es-please-read/

 

Sincere apologies for the oversized image. Will re-size in future.

Edited by GrahamV
3.5 megs is way to large. Please Resize Images to: 1024 x 768 pixels or close, before placing on HZ.

Share this post


Link to post
Share on other sites

Can someone please have a look at the attached schematic sketch I have done to try and summarise the connections described in this thread.

 

I think visual aids are easy to convey technical data, but thats just me.

 

I am sure there are corrections required by those who have done this before!

 

I like the simplicity of the diagram. I'm not really very good with electrical diagrams but this mostly makes sense to me. Perhaps a picture showing which plugs these mysterious 8 pin plugs are.

Share this post


Link to post
Share on other sites

I've been watching this thread for a while and have appreciated the shared wisdom of its users. Current putting a rb25det into a 260z. Lots of fun and expense. So my first question here is what is the this thing I have pictured and where does it go. It came with the loom. I've got most of it figured with the help from the forum but I'm much better with bits of wood and glue than cars.

 

post-181-003581000 1345510441_thumb.jpg

 

** EDIT: I re sized it for you.

 

 

Please Resize Images

http://forums.hybrid...es-please-read/

 

Sincere apologies for the oversized image. Will re-size in future.

 

I'm taking poke here but my gut tells me knock sensor?

Share this post


Link to post
Share on other sites

GrahamV. Does it also have vacuum ports on it? It looks like the stock boost controll solenoid.

Thanks 5thgenluder, my further research tell me you are right. It is also broken where the tubing fits up to it. Now I just have to decide whether to replace it or get an aftermarket control valve. The I have to find all the tubing that fits up to it. Thanks again for your help.

Share this post


Link to post
Share on other sites

Except from the pin numbers that might be diffrent form a RB25 to RB26 can i just follow the same wiring connection. All the other wires form the rb26 ECU plug can be cut off or just left alone. Im trying to start this but im nervous to cut stuff I shouldnt.

Share this post


Link to post
Share on other sites

Hey been using these wiring instructions so far to prep the harness on my rb26 for my 71 240z but it seems like there are definantly some differences. I do not have those 2 big plugs going to the body harness, insteaded i have these 4 smaller ones.

post-32972-0-15637400-1365389746_thumb.jpg

 

I have traced (pin 18) fuel pump relay, (pin 43) ignition switch start signal, (pin 32)  monitor check lamp, and (pin 7)  tach speed signal to the connector that I have circled yellow. I searched for the following (pin 45) ignition switch, (pin 28) engine temp sensor, (pin 58) battery power supply, (pin 109) injector power supply (small wire) and these wires all lead past the grommit into the engine bay without going to a body harness connector. All of my individual ground wires lead to the brown relay and then through the gromit into the engine bay instead of to the body harness. Would I be able to just splice into these wires and run them into the car to connect to ignition? would i be able to do the same for the individual ground wires?

 

I also can't find the Air regluator wire and Power wire for the vct & aac on my pinout. I see 1 thick solid red wire going to one of the smaller plugs ( labeled on picture) however i am only guessing if this is the injector power wire. my pinout shows (pin 109) injector power supply however it is a small black wire being spliced into about 4 or 5 other wires.

 

Would like to add that i have a complete r32 gtr parts car that i am pulling the parts from so i do have the complete body harness and alternator/trans harness aswell to reference too if that would help.

 

Any help would be greatly appreciated.

Thanks, Kevin

Share this post


Link to post
Share on other sites

Is this wiring setup similar for the RB20?

There are a few similarities but wiring the 20 is supposedly a bit easier - http://forums.hybridz.org/topic/90784-wiring-guide-for-installing-a-rb20det-into-a-datsun-z/?do=findComment&comment=860349. Links to ref. material are outdated tho'...

 

/bob

Share this post


Link to post
Share on other sites

RB25DET NEO WIRING!

 

Here goes

I have a 2000 RB25det.

I removed the ATTESA system. I cut it out and removed the wires going to the ECU. There are a small bundle of them and a relay. If your not keeping it and you probably wont for a Z, cut or tuck.

 

Pin 5    GRY/RED Start Signal

Pin 17  GRY?BLU MIL to 12V switched on a 10A fuse

Pin 20  GRN/ORG IGN Switch 12V

Pin 24  BLK/PNK FP Signal to 12V on the other side of the Relay(was not integrated into the EFI harness

PIN 31  WHT/BLUE IGN Switch 12V

 

ECM RELAY

Pin 6 WHT/GRN B+ 12V

Pin 1&3 WHT/BLK B+ 12V

 

They should all have 10A fuses to each power lead according to the FSM. The Start signal should have a 10A fuse as well!

 

I am running!

 

EDIT:

I missed 1 wire that is critical.

In the bundle of wires with the big white connector near the Relay packs there is a solid BROWN wire. This is the POWER wire for the IAC and the VCT! I was up and running without this and it took me until today(nearly a month later) to realize I had no VCT, but I also only drove it a handful of times. I then re-adjusted my idle and TPS and I am off and running.

Edited by rayaapp2

Share this post


Link to post
Share on other sites

I have a .4 amp draw on the alternator, does anyone else have this problem? I have tried 3 other alternators. I used the diode as mentioned in this thread, do i need a bigger one? I am using a Quest 125 amp, or whatever it is i cant remember.

Share this post


Link to post
Share on other sites

is this thread still going I need help with wiring. I have a rb20det swap, and harness and ecu are different then everyone elses ive seen. the pin out on ecu are different and so is the wiring. it has 4 separate plugs for the ecu instead of the block that bolts in. just trying to figure out the wiring I need. if anyone is familiar with this some help would be great!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×