Jump to content
HybridZ

Richard Oben

Members
  • Posts

    343
  • Joined

  • Last visited

  • Days Won

    4
  • Feedback

    0%

Richard Oben last won the day on October 5 2021

Richard Oben had the most liked content!

About Richard Oben

  • Birthday 05/05/1964

Contact Methods

  • Website URL
    www.northracecars.com

Profile Information

  • Gender
    Male
  • Location
    Kansas City MO

Recent Profile Visitors

5502 profile views

Richard Oben's Achievements

Newbie

Newbie (1/14)

4

Reputation

  1. Do you recall the length of the line from the clutch master to the slave? And did you use the OEM type connection to the slave?

     

    Thanks

    1. Richard Oben

      Richard Oben

      Not at all, found it on the hybrid z forum and bought it.  A bit long but works.  R  Sorry for the LONG delay, I never check notifications.  R

  2. As said in previous posts. If someone starts one of these conversion without a lot of research here they would be a little nuts. Glad to have helped anyone. No way I could have done it without the others who posted. From Fuel tank mods to 8.8 mods it would have been impossible, even the Radiator hoses were listed on this forum. R
  3. DonH, Thanks, it was a pain, 3 years or more of fighting this. Two problems, both on NEW parts, almost burnt it down. The rubber mount came from searching LS1 tech website and from a local tuner who is big into LS cars. On a the plus side, go drive yours, the car will be a blast, just crazy how much fun it is. Torque on demand, 70 MPH is 2k rpm even with 3.73 gears, AC and tunes. Not modern comfort but not a bad place to be. R
  4. Update again. Even with Rubber mount, still could hear the shifter rattle at 2000 RPM of engine speed about 1100 drive shaft speed. We had the drive shaft re tubed by the group that did the shaft originally. Better but not right, blurred rear view mirror at 65 mph. Took CVs off so all we had was shaft trans and differential. Still vibrated, this is when we did the rubber mount above. Took shaft out again and had it balanced, better but still not good. Took trans out and had the rear housing replaced (stripped drain plug) and some other stuff done. Mainly had the main shaft triple checked. Back together and still a small but annoying shifter rattle. In a last ditch effort before ordering a CV drive shaft we had the shaft remade by another vendor. Voila, finally can drive the car at any speed with only a minuscule vibration and they just be the LS as I can hear the same harmonic in a lot of You tube videos. Took multiple attempts but putting the miles on now is much more pleasant. Sad this forum isn't busier. Richard.
  5. My other 71 had tank problems only solved by cleaning and sealing. So the LS car (71 also) got the tank out cleaned and then a Tanks Inc in tank pump set up in it. Then sealed, pics are in my build thread. The pump never starves and never have a fuel pressure issue. It was not cheap to have done as my fab skills are worse than yours. But worth it in the end. Not my idea copied it from another guy here on the forum. 3,000 plus miles and no fuel issues. The rest of the car is chase the tail a bit but that is always the case. And yes Bone stock LS in a Z is scary fast. HTH, Richard.
  6. Great work, impressive weld and fab skills. Ease of service will be a big plus. Richard.
  7. No updates for a while. We had a small vibration, not really bad, just annoying, and of course right at 65-70 MPH. When my wife drove the car we had the 3.07 differential in it, one attempt at finding the vibration. We put the 3.73 back in (whole chunk, nothing is shared between the two). And the vibration came back. Drive shaft out, re balanced, re tubed, trans out, looking for something, anything that may cause vibration. Half shafts out, again. Trans UP diff, down to get angles better. They were not far off before. All in attempt to cure this vibration. Called a local guy I know, who does a lot, I mean a whole lot, of Ls stuff. He said "poly mount", I said yes. He said swap it out for a rubber one. Thought he was CRAZY, we have built a ton of cars with poly mount. Well, we were dead wrong. There is a whole thread on LS tech about poly mounts. Like 5 pages. Apparently T56 transmissions are very pick about the mount used on them. I have it on the lift with half shafts out, and the vibration appears to be gone. Not complaining about anything just trying to help others that may run into a problem. 3000 miles fighting this vibration, hope it is gone for good. R
  8. Keep at it! If it was easy everyone would do it. Doing good so far, no body died, LOL. It will get there, pink and all. My bet is vent is messed up or cooling lines not right. Something is building pressure, full or not. PS It is never an easy or fast process. (I'm still chasing a rattle 4 years later, ugh). R
  9. With a fixed pumpkin that is not enough engagement, there is a bearing or bushing in there that the yoke rides on. We never trust pre made shafts, measure and give a good shop dimensions. HTH, Richard.
  10. As G tech said. All depends on the computer. If the DBW computer is there use the DBW. The module is almost separate from the computer. Making room for it on the floor may be a bit of headache or super simple. Have done both DBW and DBC both work fine. HTH, Richard.
  11. Great work, and a ton of it, when you can't remember if it is 20 or 30 hours it was probably 40 LOL. The dedication to this is so very cool! This will be a very fast and safe car. Well done!
  12. Great work. Way past anything we would attempt. Master fab skills. Well done!!
  13. That is a lot of work yet to be done. But, starting from scratch is the best way to get it all correct, and the way you want it. So now the only question is blast or not to reveal anything hidden. Great work!!
  14. That is the set up I have. Works good. HTH, Richard.
  15. Just wow, I may have said that on this thread before. VERY well done. I guarantee 100% for sure just do not have your level of skill or patience. Looks great. Richard.
×
×
  • Create New...